Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm at a bit of a loss trying to get profiling and tracing working with Xdebug (debugging works fine). What's worse is that I have it working just fine on a different server/client setup, but I can't seem to see the difference that and this developer workstation using localhost. Nothing is being output to xdebug.log, either.

Server: Ubuntu 10.04, PHP 5.3.2, Xdebug 2.2.1

php.ini:

xdebug.profiler_enable=0
xdebug.profiler_enable_trigger=1
xdebug.profiler_append = 1 
xdebug.profiler_output_dir="/var/www/xdebug-profiles"
xdebug.profiler_output_name="xdebug-profile.%t.%p"

xdebug.auto_trace=0
xdebug.trace_enable_trigger=1
xdebug.trace_options = 1 
xdebug.collect_params=4
xdebug.collect_return=1
xdebug.trace_format=2
xdebug.trace_output_dir="/var/www/xdebug-traces"
xdebug.trace_output_name="trace.%t.%p"

xdebug.file_link_format="xdebug://%f@%l"
xdebug.remote_log="/var/www/xdebug.log"

The obvious answer is "permissions!" Unfortunately, I'm pretty sure that's not it:

# ls -ld /var/www/xdebug-profiles/
drwxrwxrwx 2 www-data www-data 4096 2013-01-02 10:40 /var/www/xdebug-profiles/

Using Firebug, I can see that the xdebug cookies are definitely set in the browser to trigger profiling and tracing. However, even when I disable triggered and enable global in php.ini, I still don't get any output.

Anyone have any ideas? I'm fresh out...

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Aha. After some playing around and seeing some odd things pop up in phpinfo(), it looks like "#" is deprecated for comments in php.ini, so the hash marks in my php.ini were blowing it up. Replaced them with semicolons, and now all is well. Bit tricky, that one...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.