Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was cleaning up some stuff on my C drive using SpaceSniffer, and now on my D drive, paths with spaces in them are no longer showing the short 8:3 form when using dir /X. To test things, I've created the exact same folder name on the C and D drive, and only the D drive is having this issue. Now things like my builds are broken when running on that drive. So, what could possibly do this to my drive? It's NTFS ... it had the option to index the contents, in addition to file properties (trying to remove that now), but other than that, it looks the same as the C drive.

share|improve this question

closed as off topic by SvW, Michael Hampton, mdpc, Ward, Khaled Jan 5 '13 at 8:10

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
You want 8.3 file names? What is the value of HKLM\System\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation? –  Ryan Ries Jan 4 '13 at 21:52
    
Yes, because some build scripts don't know how to handle spaces in path names, 8:3 support is required. It was working earlier today. So something changed ... NtfsDisable8dot3NameCreation is set to 2. How can that be for one drive and not the other? :S –  Richard Hein Jan 4 '13 at 21:54
    
@RyanRies So, I guess SpaceSniffer must have changed that registry key. I put it back to the default of 0, and now creating a test dir, works again. However, all the files/folders I have pulled down from source control have to be recreated. Thanks, put your comment as an answer and you get the points. :) –  Richard Hein Jan 4 '13 at 21:57

1 Answer 1

up vote 3 down vote accepted
 HKLM\System\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation

should be set to 2, which stands for "allow 8.3 file name creation to be configured on a per-volume basis." Yours was set to 2, which is good.

fsutil 8dot3name set D: 0

That will enable short name creation on the D drive.

share|improve this answer
    
Yeah it sounds like SpaceSniffer just jacked with your config and you just needed to set it back. –  Ryan Ries Jan 4 '13 at 21:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.