Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
an  5 01:09:12 vpn pptpd[1832]: GRE: read(fd=6,buffer=611860,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Jan  5 01:09:12 vpn pptpd[1832]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Jan  5 01:09:12 vpn pptpd[1832]: CTRL: Client 71.55.203.144 control connection finished
Jan  5 01:09:29 vpn pptpd[1853]: MGR: Maximum of 100 connections reduced to 1, not enough IP addresses given
Jan  5 01:09:29 vpn pptpd[1854]: MGR: Manager process started
Jan  5 01:09:29 vpn pptpd[1854]: MGR: Maximum of 1 connections available
Jan  5 01:09:36 vpn pptpd[1856]: CTRL: Client MYIP control connection started
Jan  5 01:09:36 vpn pptpd[1856]: CTRL: Starting call (launching pppd, opening GRE)
Jan  5 01:09:36 vpn pppd[1857]: Plugin /usr/lib64/pptpd/pptpd-logwtmp.so loaded.
Jan  5 01:09:36 vpn pppd[1857]: This system lacks kernel support for PPP.  This could be because the PPP kernel module could not be loaded, or because PPP was not included in the kernel configuration.  If PPP was included as a module, try `/sbin/modprobe -v ppp'.  If that fails, check that ppp.o exists in /lib/modules/`uname -r`/net. See README.linux file in the ppp distribution for more details.
Jan  5 01:09:36 vpn pptpd[1856]: GRE: read(fd=6,buffer=611860,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Jan  5 01:09:36 vpn pptpd[1856]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Jan  5 01:09:36 vpn pptpd[1856]: CTRL: Client MYIP control connection finished

I am running an OpenVZ system. Does this mean I am missing kernel modules in order for PPTP to work?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Yes:

Jan 5 01:09:36 vpn pppd[1857]: This system lacks kernel support for PPP. This could be because the PPP kernel module could not be loaded, or because PPP was not included in the kernel configuration. If PPP was included as a module, try /sbin/modprobe -v ppp'. If that fails, check that ppp.o exists in /lib/modules/uname -r`/net. See README.linux file in the ppp distribution for more details.

Did you try that? This is the solution, provided you have access to the host: http://wiki.openvz.org/PPP_in_container

It boils down to:

vzctl set [VEnumber] --features ppp:on --save
vzctl start [VEnumber]
vzctl set [VEnumber] --devices c:108:0:rw --save
vzctl exec [VEnumber] mknod /dev/ppp c 108 0
vzctl exec [VEnumber] chmod 600 /dev/ppp
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.