Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install openstack on RHEL 6.2. Following installation guide from openstack.org, I'm using the command:

yum install openstack-nova openstack-glance

After resolved many dependencies, I got the final error:

Error: Package: openstack-nova-compute-2012.2.2-1.el6.noarch (epel)
       Requires: libvirt >= 0.9.6
       Installed: libvirt-0.9.4-23.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201111171049.x86_64/6.2)
           libvirt = 0.9.4-23.el6

I installed libvirt 0.9.4 from the RHEL 6.2 DVD, but it seems I have to upgrade libvirt 0.9.6. How to do the upgrade? Or where can I download libvirt 0.9.6 rpm? Or can I use yum to upgrade libvirt?

share|improve this question

2 Answers 2

Have you tried

 yum upgrade libvirt

If this does not find the version of libvirt that you want, then you might be out of luck for the easy approach as downloading or adding this package individually via rpm might cause incompatabilities in the RH system which could make contacting RH support difficult.

If the yum upgrade does not work, I'd be inclined to contact RH support and push them to fix the incompatibility between the packages that they support that do not interoperate. This would allow RH support staff to continue to support your system.

share|improve this answer
    
I tried yum upgrade libvirt, it said "No packages marked for update". –  Evan Li Jan 5 '13 at 3:38
    
Then go contact RH support. Since these are all RH produced packages, they must be responsible for interoperation between other packages. –  mdpc Jan 5 '13 at 3:39

Update to RHEL 6.3 first. This contains libvirt 0.9.10, which will satisfy the dependency.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.