Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have started my application with this settings below:

-Dcom.sun.management.jmxremote=true
-Dcom.sun.management.jmxremote.port=43588 
-Dcom.sun.management.jmxremote.authenticate=false 
-Dcom.sun.management.jmxremote.ssl=false 
-Djava.rmi.server.hostname=***.**.***.** 

The app is running on a Centos machine. I have enabled the port via iptables. I have checked that when I run my application, the port 43588 is shown as listening.

Somehow I still get this error:

Cannot connect to ...:43588 using service:jmx:rmi///jndi/rmi://...:43588/jmxrmi?

What is my mistake? We are connecting from a windows machine.

share|improve this question

1 Answer 1

look at this: How do I fix a 'Failed to retrieve RMIServer stub' JMX error?

basically java is using yet another connection, which is not configured.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.