Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

There are 2 win7 pc, 2 100 mb/s routers and 1 ubuntu 12.04 pc.

I scanned a diagram of the Lan setup with IP's

https://lh5.googleusercontent.com/-uChF5IIApj8/UOrFVvJYMiI/AAAAAAAAEV0/lyAJAvYks9k/s1024/lan.jpeg

I can not ping from first win7 to second win7 but second win7 can ping first win7 pc.

Ubuntu pc has 2 nic, 100mb/s ethernet nic to router, gigabyte nic direct to gigabyte nic in win7 pc. Ubuntu PC has "share this connection to other pc" on. that nic is eth2 and is 10.42.0.1

2nd Win7 pc is assigned 10.42.0.19

What I want is the win7 pc on second router to ping the other win7 pc on the gigabyte lan.

The ubuntu PC can ping both win7 pc's. The first win7 pc can ping ubuntu pc but not the second win7 pc The second win7 pc can ping the ubuntu pc and the first win7 pc

This is the route command in ubuntu pc

   scott@scott-P5QC:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         wr850g.hr.cox.n 0.0.0.0         UG    0      0        0 eth2
10.42.0.0       *               255.255.255.0   U     1      0        0 eth0
192.168.1.0     *               255.255.255.0   U     1      0        0 eth2
scott@scott-P5QC:~$ 

scott@scott-P5QC:~$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth2
10.42.0.0       0.0.0.0         255.255.255.0   U         0 0          0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth2

So any ideas? I did this odd design so that I can have gigabit lan working between the ubuntu pc and the second win7 pc.

share|improve this question
    
Reading your question fast. Can you disable windows firewall on THE SECOND Win7 machine and try to ping it again? –  val0x00ff Jan 7 '13 at 13:11
    
I just tried turning off firewall it does not help. I have modified the scope rule to at least have it work a little –  Scott Jan 7 '13 at 13:56
    
shows the ping fail from first win7 to second win7https://lh4.googleusercontent.com/-hNUvIbIiDmI/UOrTV9kK9yI/AAAAAAAAEWE/BudmA‌​2vUkoA/s811/pinwin7%2520to%2520ubuntu.png –  Scott Jan 7 '13 at 13:56
    
show success from second win7 to first win7https://lh4.googleusercontent.com/-NnC6VA4io70/UOrTV-8yp-I/AAAAAAAAEWI/RCnKd‌​qcsjPg/s1040/ping%2520second%2520win7.png –  Scott Jan 7 '13 at 13:58
    
shows the ping fail from first win7 to second somehow link broke picasaweb.google.com/lh/photo/… –  Scott Jan 7 '13 at 14:03

1 Answer 1

solved by installing webmin. Then used it to reset iptables. Seriously great tool for administering the firewall. Webmin told me 2 rules were in the iptables which it could not understand, so I save iprules to a file, did a reset and all 3 pc can share files.

http://www.ubuntugeek.com/how-to-install-webmin-on-ubuntu-12-04-precise-server.html

scott@scott-P5QC:~$ sudo dpkg -i webmin_1.580_all.deb Selecting previously unselected package webmin. (Reading database ... 229686 files and directories currently installed.) Unpacking webmin (from webmin_1.580_all.deb) ... Setting up webmin (1.580) ... Webmin install complete. You can now login to xxxxxxxxxxxxxxxxxxx as root with your root password, or as any user who can use sudo to run commands as root. Processing triggers for ureadahead ... ureadahead will be reprofiled on next reboot scott@scott-P5QC:~$

shows what it looks like https://picasaweb.google.com/lh/photo/oX1xo7I07W38s4C7Laftv9MTjNZETYmyPJy0liipFm0?feat=directlink

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.