Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm struggling mightly with deploying from a web matrix site to my own personal secondary machine with IIS. I only seem to get "connection timed out"

I've installed IIS, what I would imagine to be all relevant sub features, and ensure that the remote service is started and running along with Web Deploy. Yet I cannot seem to get anything to publish.

I've followed the below article as well, but it doesn't seem to be relevant to IIS 7.5 as I do not have the management service delegation option available to me.

http://www.iis.net/learn/publish/using-web-deploy/configure-the-web-deployment-handler

It should also be noted that I've tried to deploy directly to that second PC using web matrix on that PC and configure for localhost. I receive a different error stating that the remote service is not running, when it in fact is.

Any help would be greatly appreciated, I've been combing forums for two days on this subject.

Thanks!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This has to do with management delegation. The feature is not available via a GUI on windows 7.

http://forums.iis.net/t/1159899.aspx

Was able to resolve my issue with a virtual 2008 R2 box.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.