Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I know that Hyper-V does not support creating a virtual switch together with the wireless network adapter. One previous question here on serverfault asked almost the same question, and that question answered that you could use internet connection sharing. I tried that, and it creates a new subnet from which my Hyper-V clients can access internet.

The problem is that I can't connect to my Hyper-V clients using remote desktop, as the internal subnet is not reachable from my outside servers.

I know it is very unusual to want to use the wireless network card for a server, but let's just say that on this specific server I need to do that.

Does anyone know how to set up this so that I can access the Hyper-V clients from the network?

share|improve this question
    
What sort of machine are your running Hyper-V on? –  tombull89 Jan 8 '13 at 9:05
    
It's a pure Windows 2012 Standard. The hardware is probably not important I guess, only that it is only possible to use the wireless network card. It has enough memory and harddisks, as well as CPU. –  Jonas Lewin Jan 8 '13 at 12:02
    
Machine and network? –  Michael Hampton Jan 8 '13 at 13:58
    
I'm sorry, I dont understand your question. It's a physical machine, and in this case with only one wireless network adapter. Not ideal, I know but it's what I have. –  Jonas Lewin Jan 8 '13 at 15:29
add comment

3 Answers

Windows Server 2012 DOES support wireless network adapters associated with virtual network switches in Hyper-V. When creating your virtual switch, select External as the type and select your wireless adapter from the drop down list. If this is the only network adapter in your physical server, you will also want to check the box for "allow management operating system to share this network adapter".

Update (1/16/13 - 8:30 PM) to provide more details

Ensure your wireless adapter is indeed working - driver installed and able to connect to wireless network. As you can see, my wireless adapter does show up in the list (bottom adapter in screenshot).

Adapters

When creating the Virtual switch, I select the wireless adapter from drop down list (make sure to select type of External).

Virtual switch

share|improve this answer
    
On the other Windows 2012 servers with wired lan adapters, I can create the external switch as you say. However on this server, as it only has a wireless network adapter, it does not show up in the list of network adapters. Can you please explain how you did in order to enable your wireless adapter in the virtual switch wizard? –  Jonas Lewin Jan 16 '13 at 6:23
    
@jonas lewin: I am / have edited my answer to include some screenshots of my system for reference. –  Harold Wong Jan 17 '13 at 3:29
    
I have now tried, and my Atheros AR9271 Wireless Network Adapter does not show up in the list. The Atheros chip supports promiscuous mode, but for some reason I am not able to create an external switch, as this network card does not show up in the list. I appreciate your answer Harold, and the fact that you took the time to make the screenshots to show me that yours is working just fine. –  Jonas Lewin Jan 18 '13 at 18:42
    
Are you able to connect to a wireless network successfully? –  Harold Wong Jan 18 '13 at 23:04
    
Yes, I can connect to the wireless without any problems. –  Jonas Lewin Jan 21 '13 at 5:22
show 1 more comment

Another option you can use to enable the wireless card is the same thing you had to do in 2008 or 2008 R2 to enable the use of the wireless card on hyper-v. You can bridge the network. There is a step-by-step guide that shows how to do this at http://itproguru.com/expert/2012/08/configure-windows-server-2008-r2-lab-environment-hands-on-guide/ It is a bit of a drawn out process but it is pretty simple. Start following the instructions at Step #9.

share|improve this answer
    
I tried that before I asked the question. The problem with briding is that it will not create a new private virtual network, meaning that I can't setup web servers / access them via remote desktop as they have no "public" ip address. Harolds answer was great, but it seems that it will not work at all on my server. –  Jonas Lewin Feb 2 '13 at 17:06
add comment

Try this if you want to have a NAT between your VMs and the physical network or this if you want to get separate IPs for your VMs on the physical network.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.