Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a DELL server running RedHat EL 6.3 with two 1G network interfaces, and two 10G network interfaces.

Following this note, I have successfully renamed the two 1G network interfaces that used to be called em1 and em2. However, I cannot rename the 10G network interfaces using this method. (Those are called p4p1 and p4p2, and do not start with em.)

How can I rename the network interface name of my 10G network interfaces on RedHat EL 6.3?

share|improve this question
    
If you're just renaming them back to the old eth* names, you're just wasting your time and setting yourself up for trouble in the future. The consistent naming feature makes your job easier; it's strongly recommended to use them. –  Michael Hampton Jan 8 '13 at 16:41
    
I'm renaming them back to eth* names because I have no choice. A certain piece of software (which I have no control over) imposes the eth* names. –  Randomblue Jan 8 '13 at 16:43
1  
Oh, what an unholy mess some of those old legacy software... –  Michael Hampton Jan 8 '13 at 16:44
    
Beware that recent udev (really systemd) versions no longer support assigning stable eth* names to interfaces (although this obviously won't affect RHEL6, the new code may turn up in RHEL7). A workaround I can think of is using numbers which are not less than the total number of interfaces in the system (e.g., if you definitely do not expect more than 4 eth* interfaces, you can assign stable names starting with eth4, so that they will not overlap with names automatically assigned by the kernel). –  Sergey Vlasov Jun 3 '13 at 15:03

1 Answer 1

up vote 3 down vote accepted

As the section of the appendix you linked to states, it's strongly recommended to enable or disable the consistent network device naming feature at install time; doing so after installation is messy and not guaranteed to work, as you've discovered.

To do this, install the system passing biosdevname=0 on the boot command line when booting the installation media, and add the same parameter to the grub boot command line.

Since you've just installed the system anyway, this shouldn't be too big of a headache...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.