Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm following the official documentation to install the 3.0.2 version of VSFTPd.

Commands.

$ wget https://security.appspot.com/downloads/vsftpd-3.0.2.tar.gz
$ tar xvfz vsftpd-3.0.2.tar.gz
$ cd vsftpd-3.0.2/
$ make
$ mkdir /usr/share/empty/
$ mkdir /var/ftp/
$ useradd -d /var/ftp ftp
$ chown root.root /var/ftp
$ chmod og-w /var/ftp
$ cp vsftpd /usr/local/sbin/vsftpd
$ cp vsftpd.conf.5 /usr/local/man/man5
$ cp vsftpd.8 /usr/local/man/man8
$ make install

And I get this error after make install:

if [ -x /usr/local/sbin ]; then \
    install -m 755 vsftpd /usr/local/sbin/vsftpd; \
else \
    install -m 755 vsftpd /usr/sbin/vsftpd; fi
if [ -x /usr/local/man ]; then \
        install -m 644 vsftpd.8 /usr/local/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/local/man/man5/vsftpd.conf.5; \
elif [ -x /usr/share/man ]; then \
        install -m 644 vsftpd.8 /usr/share/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/share/man/man5/vsftpd.conf.5; \
else \
        install -m 644 vsftpd.8 /usr/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/man/man5/vsftpd.conf.5; fi
install: accessing `/usr/local/man/man8/vsftpd.8': Not a directory
install: accessing `/usr/local/man/man5/vsftpd.conf.5': Not a directory
make: *** [install] Error 1

Can anyone help me to fix it?

share|improve this question
1  
Read the error message and make the needed directories. –  mdpc Jan 8 '13 at 18:57
    
I do that, but doesn't install again! mkdir -p /usr/local/man/man8 /usr/local/man/man5 –  Caio Tarifa Jan 8 '13 at 18:58
1  
While I am a big fan of using distro tools to install software, needing a newer version then the one shiped with your distro is one of the few exceptions I would make. Ubuntu ships 2.x, the poster wants 3.0.2 –  Isaac Jan 8 '13 at 19:21
1  
I just tried this on a ubuntu 12.04 system. I got the same error, but creating the missing directories fixed it. Maybe you forgot to use 'sudo' ? like 'sudo make install' ? –  Isaac Jan 8 '13 at 19:25
1  
It tells you that the makefile does not define a "target" named "install-vsftpd". So there is not much you can do about it :) Where did you get the idea, that this target installs the bootscript? Maybe that ressource assumes a different makefile. –  Isaac Jan 10 '13 at 8:44

1 Answer 1

up vote 1 down vote accepted

Try to create directories man5 and man8 by mkdir -p /usr/local/man/man8 and mkdir -p /usr/local/man/man5 if they aren't exist.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.