Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am looking at a W2K3 R2 SP2 server that was created from a straight update from a W2K Server. All the folders in all the HDD's are labeled "Read Only" ??? If I try to change their attributes (as Admin) I can go through the entire process, but when done, the attribute did not change??? huh???

Anyhow, it has one folder containing about 5K files and another with 58K files. I need to delete all the mp3 files in those folders (this is *.mp3) but nothing, and I mean absolutely nothing, seem to work. The files were copied from DVD's and CD's. I tried the GUI search / select all files / delete and I get a "cannot delete file: cannot read from source or disk". However if I select files one at the time, I can delete them OK. I have tried other GUI software such as Total Commander and FileBoss with no results. These apps cannot any mp3 files nor delete them but they can list the contents of both folders OK.

I went command line. If I use Del /s I get nothing again. It can't find any file. The ONLY thing that works is del r:\ /s /p *.mp3 which is not even a standard del command format. Problem is, it deletes all mp3 files from the entire drive, not only the two target folders.

I have tried other permutations without any luck. I have tried PowerShell with the same result = no result.

I have even loaded CygWin and run a few simple commands to scripts with the exact same result. It cannot find or delete any mp3 files.

Then, I took a few mp3 files and dump them in a test directory in the same drive, and suddenly ALL the above mentioned methods worked, WTF!!!???

Just in case I run chkdsk on R and came out squeaky clean.

Obvioulsy there is some sort of retarded limitation either on W2K3 or in the NTFS file system. Any help would be enormously appreciated.

share|improve this question
add comment

1 Answer

The two issues are unrelated. See here for a description of the READ-only attribute on the folder:

http://support.microsoft.com/kb/326549

Files copied from CD or DVD are copied as READ-only. You'll need to remove the READ-only attribute from the files in order to delete them. You can do that from the command line (attrib -R /S *.mp3) or from Windows Explorer (multi-select then uncheck READ-only).

There's nothing wrong with the delete command you've used. /S specifies "Delete specified files from all subdirectories" and *.mp3 will match all MP3 files, so all MP3 files in all subdirectories on the R: drive will be deleted.

share|improve this answer
    
Hi, thank you for the ms Kb article. Wasn't aware of that. BTW, I followed MS's article and did nothing.... so much for MS advice... However, wrt the deletion, I removed the file's attributes long time ago. They are all R/W and the command del /S *.mp3 does not work. As mentioned above, nothing seems to work, not even cygwin. –  user152554 Jan 9 '13 at 0:57
    
Just one clarification, I don't want to delete all the mp3 files from the drive, only from two folders. –  user152554 Jan 9 '13 at 1:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.