Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the following configuration.

Some Websites in IIS one of them with a virtual directory. This virtual directory is configured as webdav which is fully functional without any problems.

This virtual directory has the following directory structure:

    -dir1 (ok)
    -dir2 (ok)
    -dir3 (ok)
    -dir4 (ok)
    -dir5 (virtual directory)
        -dir1 (ok)
            -dir1 (ok)
            -dir2 (ok)
            -dir3 (ok)
            -dir4 (ok)
            -dir5 (HTTP Error 500)
        -dir2 (ok)
        -dir3 (ok)

Any directory is accessible without any problem except of dir5. If I try to acces this directory I get an HTTP error 500. Here is what the IIS logfiles contains:

2013-01-08 21:17:03 W3SVC2 WEB XXX.XX.XXX.XXX PROPFIND /WebDav/dir5/dir1/dir5 - 443 - XXX.XX.XXX.XXX HTTP/1.1 Microsoft-WebDAV-MiniRedir/6.1.7601 - - 500 50 183 1397 204 78

I can not explain me why I get this error for this directory.

share|improve this question

The sc-win32-status code (the value after the HTTP return code) has a value of 50 which translates to "The request is not supported". This might be a Request Filtering issue on the directory.

If you have the Request Filtering feature enabled, open the IIS Manager, navigate to the directory and select "Request Filtering" from the feature pane. If there are any restrictions, you might be able to solve it by excluding webDAV requests from filtering:

appcmd set config /section:requestfiltering /fileExtensions.applyToWebDAV:false
share|improve this answer
Thank you for your answer. In my request filter rules are only the booth default rules. – Marcel Janus Jan 10 '13 at 14:12
Just disabled the filtering for Webdav but I still get the same error. – Marcel Janus Jan 17 '13 at 12:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.