Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed Microsoft's Web Farm Framework on a cluster of 4 web servers. I need to take the primary down to reinstall the OS and I want to change the primary server to one of the other servers. The WFF controller is installed on the primary.

I found it easy enough to designate one of the secondary servers as primary. In IIS Manager, under the correct server farm node, right-click on the server that I want to make primary and select "Designate as Primary Server".

The question is, how do I designate a new server as the controller? Can I move/copy the existing server farms? Or do I need to create new server farms and delete it from the old controller? Any other advice?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The way I solved this is I installed the WFF controller on the new server and recreated the web farm.

To recreate the web farm, I think you can copy the node (or just the parts you want) from the applicationHost.config file on the old controller and paste it into the config on the new controller (the adminPassword value will probably be different). This has the added benefit of being able to copy any additional configuration you might have (I've defined skipDirectives) The applicationHosts.config file is located in %windir%\System\inetsrv\config.

The tricky part was installing WFF on the new controller. Basically WFF v2 requires Web Platform Installer v3. The current version of WPI is 4. You can install v3 from http://www.microsoft.com/en-us/download/details.aspx?id=6164. If you run v3, it will ask you to update to v4. Click the X in the top right corner to close this dialog and keep running v3.

For some reason, I couldn't find WFF v2 (it had v1). I was able to download v2 from http://www.microsoft.com/en-us/download/details.aspx?id=27723.

After configuring everything, the secondary servers "Current Operation" seemed stuck on a couple operations. I waited several hours, but it never worked itself out. I ended up restarting the controller server and everything seems to be working correctly now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.