Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am a front-end developer and am managing my own linux server for the first time. I'm running Ubuntu 12.04 LTS, and have an SSL certificate. Using Google apps mail as my mailserver, and SendGrid to send out emails from my application.

To integrate SendGrid into postfix, SendGrid docs state to add the code below to /etc/postfix/main.cf and restart the server:

smtp_sasl_auth_enable = yes 
smtp_sasl_password_maps = static:yourSendGridUsername:yourSendGridPassword 
smtp_sasl_security_options = noanonymous 
smtp_tls_security_level = may
start_tls = yes
header_size_limit = 4096000
relayhost = [smtp.sendgrid.net]:587

I've made these updates. Once the server restarts, I am getting the error messages below. Each message repeats 8-10 times or so:

* Starting Postfix Mail Transport Agent postfix
postconf: warning: /etc/postfix/main.cf: unused parameter: start_tls=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: start_tls=yes

/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: start_tls=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: start_tls=yes

Any idea what's causing these messages and how to fix them?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

While your question is not a duplicate of it, it appears that an existing question RE: SendGrid settings contains the solution. Refer to @adaptr's comment.

Configuring Postfix with other SMTP provider

share|improve this answer
    
Thank you for this. I've accepted and upvoted your answer. It's a good research starting point for me, and it resolved the issue. For anyone googling this issue, the comment Andrew B refers to is here - serverfault.com/questions/425951/… –  chowwy Jan 10 '13 at 5:29
    
Sweet, I didn't know how to find those direct comment links. Thanks! –  Andrew B Jan 10 '13 at 17:30

As found in the linked question, start_tls = yes isn't valid. Use this instead:

smtp_tls_security_level = encrypt
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.