Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting a strange error message from Apache when I try to start the server

.

     * Restarting web server apache2                                                apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Thu Jan 10 17:49:32 2013] [warn] NameVirtualHost 122.174.238.1XX:0 has no VirtualHosts
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Thu Jan 10 17:49:32 2013] [warn] NameVirtualHost **122.174.238.1XX:0** has no VirtualHosts
(99)Cannot assign requested address: make_sock: could not bind to address 122.174.238.1XX:80
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
                                                                         [fail]

The strange thing is I have no idea where it is getting 22.174.238.1XX IP from

I have one file in sites-enabled :

   <VirtualHost 192.168.1.90:80>
DocumentRoot "/home/webmaster/www/thefaXXXX"
ServerName thefaXXXXX.cu.cc
<Directory "/home/webmaster/www/thefaXXXXX">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

My hosts file in /etc/ reads

    127.0.0.1       localhost
127.0.1.1       NightHwack
192.168.1.90    thefaXXXX.cu.cc
192.168.1.90    www.thefaXXXX.cu.cc
# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

I wnat my server to listen on 192.168.1.90 at port 80. I tried deleting the virtual server with webmin and creating a new one that listens on192.168.1.90 (without server names etc) but still get exactly the same error.

I can't understand where apache is picking up the 122...* IP from

share|improve this question
    
Please check /etc/apache2/ports.conf –  pauska Jan 10 '13 at 12:33
    
yeh it had that IP inside it, removed it –  blas Jan 10 '13 at 12:45
    
added it as an answer now, please accept it :-) –  pauska Jan 10 '13 at 13:10

1 Answer 1

up vote 1 down vote accepted

You have a static IP defined inside /etc/apache2/ports.conf. Reconfigure the file to fix the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.