Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have got a website (hosted locally but available over the internet) that does not work for everybody. The problem has been reported by internal users having windows vista home. If they go on our website with this address http://example.com, everything is fine. If the address is http://www.example.com it doesn't work, they get a simple error message that suggest to reload the page. It's not all Vista users that have this problem.

For the rest of our group, both address are working. Our server (Windows Server 2008) accept both headers. Cache has been cleared and all browser get the same error on those vista home, so I don't know what to do more. Maybe it's a server security? Any ideas?


As suggested by @TheCleaner I did a ping to our website:

On Windows 7

I get a 209.161.xxx.xx for both website (It's the good address)

On Vista

I get a 208.69.xx.xxx for the website with www. (the 209.161.xxx.xx should be the good one...but I see my website)
I get a 192.168.1.25 without the www. (this was an old server that crashed about 2 month ago)

How do I resolve this? Thanks

share|improve this question

migrated from security.stackexchange.com Jan 10 '13 at 19:12

This question came from our site for Information security professionals.

    
Can these problematic clients ping "www.example.com"? Do they get the same results as pinging example.com? –  TheCleaner Jan 10 '13 at 19:18
    
if ping is blocked, can they do an nslookup for each record and compare the results to ensure they are both resolvable and resolving to the same address. –  Rex Jan 10 '13 at 19:32
    
In addition, what holds the internet facing IPs? Is it the server itself, or a network device such as a load balancer? –  Andrew B Jan 10 '13 at 19:33
    
Vista home? Really? Sounds like the excuse you need to get rid of Vista home from your network. Upgrade to a professional edition of a Windows desktop OS. –  HopelessN00b Jan 10 '13 at 19:51
3  
@Shadowizoo You need to do a software inventory, report your boss to the BSA for his illegal activities (using the software inventory as proof), and use the reward money to live off of while you find a new job. Seriously. –  HopelessN00b Jan 17 '13 at 14:41

1 Answer 1

up vote 0 down vote accepted

Are any/all of these clients connected via a proxy, or do they access the server directly? It sounds like there's some legacy stuff hanging around. Can you check the C:/Windows/system32/drivers/etc/hosts file to see if the server has some nasty hard coded stuff in there?

share|improve this answer
    
You hit directly the problem. There was junk (over 500 of website junk) Thanks !!!! –  Shadowizoo Jan 17 '13 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.