Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a HP server which has Windows Server 2008 as OS. I also have an Ubuntu server VM running with Hyper-V. My ubuntu server runs a web application which connects to MS SQL Server running on the windows side. Suddenly the connection between two servers stopped working, I can't access to SQL Server from guest OS (ubuntu server) even when ports are open or firewall disabled.

My server has two network interfaces, so I connected my ethernet wire to the other adapter. Then I disabled the first interface and enabled the second one, where my ethernet is now plugged. Doing this solved the problem between two servers, now I can access my MS SQL server database from my Ubuntu server, this made me think that firewall is ok. The problem is that I can't access to internet or even to the local network from this interface. Both servers have static ip's on LAN, but other computers on same LAN can't reach them. The enabled network interface is marked as "Unknown connection".

Any idea on how to solve this or where do I must start? With my old configuration, I can't even ping the Windows Server from Ubuntu but I can achieve this from other windows workstations. How do I configure the network interface in order to have internet and local network access.

Your suggestions will be greatly aprreciated. Thanks

share|improve this question
Could you post a ipconfig / ifconfig from the two servers, and one working computer on the LAN? – QuentinMoss Jan 10 '13 at 23:51
I've solved the problem enabling both adapters, for some reason the first adapter has internet access and the second one local network access. I hope someone could explain me this since I'm not an OS or network administrator. Both interfaces have different static IPs on same LAN. – Jorge Zapata Jan 11 '13 at 21:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.