Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a lab of computers with printers being deployed to and set as default with Group Policy Preferences, but we're getting a large number of users who don't pick up the default settings. There's another local printer already installed and it's being left as the default after our policy has applied. We use similar policies in dozens of other labs without trouble.

Here's the trace after enabling GPP logging for printers:

2013-01-10 11:49:11.810 [pid=0x488,tid=0x77c] Completed get GPH path. [SUCCEEDED(S_FALSE)]
2013-01-10 11:49:11.810 [pid=0x488,tid=0x77c] Completed remove GPH. [SUCCEEDED(S_FALSE)]
2013-01-10 11:49:11.826 [pid=0x488,tid=0x77c] Read GPE XML data file (496 bytes total).
2013-01-10 11:49:11.826 [pid=0x488,tid=0x77c] RunOnce value created [SUCCEEDED(S_FALSE)]
2013-01-10 11:49:11.841 [pid=0x488,tid=0x77c] Properties handled. [ hr = 0x8007000a "The environment is incorrect." ]
2013-01-10 11:49:11.857 [pid=0x488,tid=0x77c] Error suppressed. [ hr = 0x8007000a "The environment is incorrect." ]
2013-01-10 11:49:11.857 [pid=0x488,tid=0x77c] Completed get next GPO. [SUCCEEDED(S_FALSE)]
2013-01-10 11:49:11.857 [pid=0x488,tid=0x77c] WQL : SELECT * FROM RSOP_PolmkrSetting WHERE polmkrBaseCseGuid = "{########-####-####-####-############}"
2013-01-10 11:49:11.857 [pid=0x488,tid=0x77c] Purged 0 old RSoP entries.
2013-01-10 11:49:11.857 [pid=0x488,tid=0x77c] Logging 1 new RSoP entries.
2013-01-10 11:49:11.873 [pid=0x488,tid=0x77c] RSoP Entry 0
2013-01-10 11:49:11.873 [pid=0x488,tid=0x77c] Completed get GPO list. [SUCCEEDED(S_FALSE)]

The obvious line that identifies a problem is hr = 0x8007000a "The environment is incorrect.", but I have yet to find a concrete answer on how to resolve it. The drivers were pre-installed on this particular image so my next step may be to re-image a few machines without the driver included.

Other than that, anybody else ran across this or have other ideas on where to look to troubleshoot?

share|improve this question
    
Have you installed this hotfix? support.microsoft.com/kb/2748246 –  Nic Feb 8 '13 at 15:28

1 Answer 1

It possible that your GPO try execute, but the network not completely ready.

Try modify you GPO "Always wait for the network at computer startup and logon" For that:

Try modify you GPO and enable "Always wait for the network at computer startup and logon" in Computer configuration -> Administrative template -> System -> Logon

enter image description here

Source: http://technet.microsoft.com/en-us/magazine/gg486839.aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.