Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We just tried to do a launch and when we started changing the "a records" for multiple domains to point to the new IP. The server had one domain pointing to the IP for days and it was working fine but as soon as we switched the "a records", the new IP stopped working.

Its Linux / Ubuntu 12 / Apache2. Its VPC on EC2 with a IP based virtual hosting. We have 2 public IPs pointing to the server.

One of the IPs worked fine but the other IP stopped working once the other domain "a records" were changed.

So what it looks like is that having multiple domains pointing to one IP will make that IP stop working. I do not see any reason for this though. Nothing in the logs.

share|improve this question
1  
Could you provide those two VirtualHost definitions in block quotes please? It would greatly assist with troubleshooting this. –  Andrew B Jan 11 '13 at 6:05
1  
Also, what exactly you mean by stopped working .. is it like your VirtualHost is not working, or your IP is not working ? –  GeekRide Jan 11 '13 at 9:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.