Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


but yum is not working when i use

[root@localhost ~]# rpm -q yum yum-3.2.22-26.el5

when i run

[root@localhost ~]# yum update
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Skipping security plugin, no data
Setting up Update Process
No Packages marked for Update

when i tried to install another version of yum it gives

[root@localhost ~]# rpm -ivh yum-3.2.29-30.el6.noarch.rpm 
warning: yum-3.2.29-30.el6.noarch.rpm: Header V4 DSA signature: NOKEY, key ID 192a7d7d
error: Failed dependencies:
        pygpgme is needed by yum-3.2.29-30.el6.noarch
        python(abi) = 2.6 is needed by yum-3.2.29-30.el6.noarch
        python-urlgrabber >= 3.9.0-8 is needed by yum-3.2.29-30.el6.noarch
        rpmlib(FileDigests) <= 4.6.0-1 is needed by yum-3.2.29-30.el6.noarch
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by yum-3.2.29-30.el6.noarch
        yum-basearchonly conflicts with yum-3.2.22-26.el5.noarch
        yum-skip-broken conflicts with yum-3.2.22-26.el5.noarch

please help me in this how can i use yum

share|improve this question

closed as unclear what you're asking by Ward, Jenny D, dawud, EEAA, HBruijn May 20 '15 at 7:14

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

Do you have a valid license from RedHat? That sounds like you might not have access to RHN (RedHat Network) because you're not paying RedHat. – ptman Jan 11 '13 at 11:54
Besides not being registered with RHN, you're trying to manually install an RPM from RHEL 6 onto an RHEL 5 system. That's what the 'el6' in the rpm filename means. – yoonix Jan 11 '13 at 22:31

It clearly states that your systen isn't registered with RedHat, which is required to get security updates. Either buy/register a support license or switch to something else (like CentOS).

share|improve this answer

Looks like u haven't configured any repositories to use yum with and as @SvenW said - no rhn support here. Check directory /etc/yum.repos.d for configs.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.