Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Windows 2003 server acting as a print server for our Konica/Miolta 7222 Biz Hub, among others. Recently the driver was updated on the server to the incorrect version (Why Konica has a "special" driver for something is beyond me). That was caught fairly quickly and the correct driver was then installed.

On some XP clients, the incorrect driver was updated causing a password prompt (part of the driver) to be displayed. After the second update they password box went away. On a few clients; however, the password prompt continues, signifying the incorrect driver is still installed even though it is days and several reboots later.

We have tried removing the printer from the affected clients and adding them back, but that has not worked. Attempting to delete the driver from the clients also fails with the message "The files may be in use". This occurs even right after a clean boot. We cannot do it in safe mode because the drivers will not come up without the spooler service running, and that is one service that will not run in safe mode.

Any help or suggestions would be greatly appreciated.

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted
  • Remove the printer "connection" from the client computer by deleting it from the "Printers and Faxes" dialog.

  • After it's deleted, go to "File / Server Properties".

  • On the "Drivers" tab, find and remove the driver for the device there.

  • Add the printer "connection" to the client again through whatever means you've previously used.

  • Verify that you now have the correct driver version.

share|improve this answer
    
Following the those steps only gets me to item 3. That is where the "The file is in use" always occurs, even after a clean reboot. –  palehorse Jul 27 '09 at 17:54
1  
There's no indication of what file is "in use"? Grab a copy of "handle.exe" from Microsoft (technet.microsoft.com/en-us/sysinternals/bb896655.aspx), run it with the "-a" argument dumping the results out of a file ("handle -a > foo.txt") and look thru that text file for references to "C:\WINDOWS\SYSTEM32\SPOOL\DRIVERS\..." files. It sounds like some piece of the driver runs as a user-land process. Worst-case scenario, stop the spooler service, delete the reference to the driver from its subkey in HKLM\System\CurrentControlSet\Control\Print\Environments, then restart the spooler. –  Evan Anderson Jul 27 '09 at 18:01
1  
@palehorse: You can also use Unlocker (download.cnet.com/Unlocker/3000-2248_4-10493998.html) to find out what is using the files and try to unlock it via that program. Then try to remove the drivers. –  JFV Jul 27 '09 at 18:08
    
I was finally able to get it done. I had to stop the spooler then delete the files by hand since you can't use the Remove driver button when the spooler is stopped. Thanks for the tips! –  palehorse Jul 27 '09 at 19:57
1  
My experience is that, when you are trying to remove a print driver and you stuck with 'the file is in use', then you simply need to restart the spooler service. –  Zoredache Jul 27 '09 at 22:15
add comment

Just thought I'd add to this as I had exactly the same problem and had to do a bit of research to sort it out. Basically we'd installed a new print driver on our print server later to find it was causing a problem, we then reverted the print driver to the old version on the server, but we found the xp clients we're still using the new (faulty) version of the driver. To fix this I used the prndrvr.vbs script (http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/prndrvr.mspx) to remove the print driver on logoff (had to also include a couple of lines to stop and start the print spooler service before running the script to get it to work). Then when the users logged in again they picked up the driver from the server. Hope this helps someone else.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.