Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Verizon USB 3G modem that I want the connection to automatically start with on boot. In my Debian based system in /etc/network/interfaces I have the following:

auto ppp0
iface ppp0 inet ppp
 provider verizon

When it's booting, everything appears to be working as I see TTYACM0 acquiring the network address from my modem. However, when I ifconfig, my ppp0 interface does not appear, thus it appears that ppp has not been configured. Manually running pppd call verizon from the terminal successfully intiates the connection. Why is it not working on bootup?

share|improve this question

1 Answer 1

you can try pre-up option and call your command there. like this:

auto ppp0
iface ppp0 inet ppp
 provider verizon
pre-up pppd call verizon
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.