Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Centos 64-bit 6.3 on Hyper-V 2012. Logged in to the local console via the Hyper-V Virtual Machine Connection, I type startx but get the following failure and message:

startx

I do not have a frame buffer device /dev/fb0.

When I install CentOS, there is a graphical console - so for sure Hyper-V can display graphics (it also runs SuSe Live CDs no problem).

I can accept an emulated graphics device (doesn't need to be blazing fast) or even remote VNC desktop connection (for remote desktop from another machine). One important point is that I do not want to install the integration components, is there any way I can get it working with the above conditions please?

X -configure dumps the following:

[  1788.620] 
X.Org X Server 1.10.6
Release Date: 2012-02-10
[  1788.636] X Protocol Version 11, Revision 0
[  1788.640] Build Operating System: c6b9 2.6.32-220.el6.x86_64 
[  1788.644] Current Operating System: Linux bacula0 2.6.32-279.19.1.el6.x86_64 #1 SMP Wed Dec 19 07:05:20 UTC 2012 x86_64
[  1788.648] Kernel command line: ro root=/dev/mapper/vg_bacula0-lv_root rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=129M@0M rd_LVM_LV=vg_bacula0/lv_root  KEYBOARDTYPE=pc KEYTABLE=us rd_LVM_LV=vg_bacula0/lv_swap rd_NO_DM rhgb quiet
[  1788.659] Build Date: 22 June 2012  08:01:35PM
[  1788.663] Build ID: xorg-x11-server 1.10.6-1.el6.centos 
[  1788.670] Current version of pixman: 0.18.4
[  1788.676]    Before reporting problems, check https://www.redhat.com/apps/support/
    to make sure that you have the latest version.
[  1788.687] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1788.726] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan 12 20:54:55 2013
[  1788.731] (II) Loader magic: 0x7d51a0
[  1788.731] (II) Module ABI versions:
[  1788.731]    X.Org ANSI C Emulation: 0.4
[  1788.731]    X.Org Video Driver: 10.0
[  1788.731]    X.Org XInput driver : 12.2
[  1788.731]    X.Org Server Extension : 5.0
[  1788.737] (--) PCI:*(0:0:8:0) 1414:5353:0000:0000 rev 0, Mem @ 0xf8000000/67108864, BIOS @ 0x????????/131072
[  1788.738] List of video drivers:
[  1788.741]    sisusb
[  1788.747]    ast
[  1788.753]    savage
[  1788.763]    i740
[  1788.769]    vmware
[  1788.776]    voodoo
[  1788.782]    apm
[  1788.789]    sis
[  1788.795]    ati
[  1788.801]    trident
[  1788.809]    glint
[  1788.815]    rendition
[  1788.821]    xgi
[  1788.827]    mach64
[  1788.833]    nouveau
[  1788.839]    intel
[  1788.845]    tdfx
[  1788.863]    cirrus
[  1788.869]    radeon
[  1788.875]    vmwlegacy
[  1788.882]    nv
[  1788.889]    i128
[  1788.896]    mga
[  1788.904]    siliconmotion
[  1788.913]    openchrome
[  1788.920]    dummy
[  1788.928]    v4l
[  1788.934]    r128
[  1788.941]    qxl
[  1788.949]    s3virge
[  1788.956]    fbdev
[  1788.962]    vesa
[  1788.969] (II) LoadModule: "sisusb"
[  1788.969] (II) Loading /usr/lib64/xorg/modules/drivers/sisusb_drv.so
[  1788.969] (II) Module sisusb: vendor="X.Org Foundation"
[  1788.969]    compiled for 1.10.4, module version = 0.9.4
[  1788.969]    Module class: X.Org Video Driver
[  1788.969]    ABI class: X.Org Video Driver, version 10.0
[  1788.969] (II) LoadModule: "ast"
[  1788.970] (II) Loading /usr/lib64/xorg/modules/drivers/ast_drv.so
[  1788.970] (II) Module ast: vendor="X.Org Foundation"
[  1788.970]    compiled for 1.10.4, module version = 0.91.10
[  1788.970]    Module class: X.Org Video Driver
[  1788.970]    ABI class: X.Org Video Driver, version 10.0
[  1788.970] (II) LoadModule: "savage"
[  1788.970] (II) Loading /usr/lib64/xorg/modules/drivers/savage_drv.so
[  1788.970] (II) Module savage: vendor="X.Org Foundation"
[  1788.970]    compiled for 1.10.4, module version = 2.3.2
[  1788.970]    Module class: X.Org Video Driver
[  1788.970]    ABI class: X.Org Video Driver, version 10.0
[  1788.970] (II) LoadModule: "i740"
[  1788.970] (II) Loading /usr/lib64/xorg/modules/drivers/i740_drv.so
[  1788.970] (II) Module i740: vendor="X.Org Foundation"
[  1788.970]    compiled for 1.10.4, module version = 1.3.2
[  1788.970]    Module class: X.Org Video Driver
[  1788.970]    ABI class: X.Org Video Driver, version 10.0
[  1788.970] (II) LoadModule: "vmware"
[  1788.971] (II) Loading /usr/lib64/xorg/modules/drivers/vmware_drv.so
[  1788.971] (II) Module vmware: vendor="X.Org Foundation"
[  1788.971]    compiled for 1.10.4, module version = 11.0.3
[  1788.971]    Module class: X.Org Video Driver
[  1788.971]    ABI class: X.Org Video Driver, version 10.0
[  1788.971] (II) LoadModule: "vmwgfx"
[  1788.972] (WW) Warning, couldn't open module vmwgfx
[  1788.972] (II) UnloadModule: "vmwgfx"
[  1788.972] (II) Unloading vmwgfx
[  1788.972] (EE) Failed to load module "vmwgfx" (module does not exist, 0)
[  1788.975] (EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
[  1788.980] (II) vmware: Using vmwlegacy driver everything is fine.
[  1788.980] (II) LoadModule: "vmwlegacy"
[  1788.980] (II) Loading /usr/lib64/xorg/modules/drivers/vmwlegacy_drv.so
[  1788.980] (II) Module vmwlegacy: vendor="X.Org Foundation"
[  1788.980]    compiled for 1.10.4, module version = 11.0.3
[  1788.980]    Module class: X.Org Video Driver
[  1788.980]    ABI class: X.Org Video Driver, version 10.0
[  1788.980] (II) LoadModule: "voodoo"
[  1788.981] (II) Loading /usr/lib64/xorg/modules/drivers/voodoo_drv.so
[  1788.981] (II) Module voodoo: vendor="X.Org Foundation"
[  1788.981]    compiled for 1.10.4, module version = 1.1.0
[  1788.981]    Module class: X.Org Video Driver
[  1788.981]    ABI class: X.Org Video Driver, version 10.0
[  1788.981] (II) LoadModule: "apm"
[  1788.981] (II) Loading /usr/lib64/xorg/modules/drivers/apm_drv.so
[  1788.981] (II) Module apm: vendor="X.Org Foundation"
[  1788.981]    compiled for 1.10.4, module version = 1.2.3
[  1788.981]    Module class: X.Org Video Driver
[  1788.981]    ABI class: X.Org Video Driver, version 10.0
[  1788.981] (II) LoadModule: "sis"
[  1788.981] (II) Loading /usr/lib64/xorg/modules/drivers/sis_drv.so
[  1788.981] (II) Module sis: vendor="X.Org Foundation"
[  1788.981]    compiled for 1.10.4, module version = 0.10.3
[  1788.981]    Module class: X.Org Video Driver
[  1788.981]    ABI class: X.Org Video Driver, version 10.0
[  1788.981] (II) LoadModule: "ati"
[  1788.982] (II) Loading /usr/lib64/xorg/modules/drivers/ati_drv.so
[  1788.982] (II) Module ati: vendor="X.Org Foundation"
[  1788.982]    compiled for 1.10.4, module version = 6.14.2
[  1788.982]    Module class: X.Org Video Driver
[  1788.982]    ABI class: X.Org Video Driver, version 10.0
[  1788.982] (II) LoadModule: "trident"
[  1788.982] (II) Loading /usr/lib64/xorg/modules/drivers/trident_drv.so
[  1788.982] (II) Module trident: vendor="X.Org Foundation"
[  1788.982]    compiled for 1.10.4, module version = 1.3.4
[  1788.982]    Module class: X.Org Video Driver
[  1788.982]    ABI class: X.Org Video Driver, version 10.0
[  1788.982] (II) LoadModule: "glint"
[  1788.982] (II) Loading /usr/lib64/xorg/modules/drivers/glint_drv.so
[  1788.982] (II) Module glint: vendor="X.Org Foundation"
[  1788.982]    compiled for 1.10.4, module version = 1.2.5
[  1788.982]    Module class: X.Org Video Driver
[  1788.982]    ABI class: X.Org Video Driver, version 10.0
[  1788.982] (II) LoadModule: "rendition"
[  1788.983] (II) Loading /usr/lib64/xorg/modules/drivers/rendition_drv.so
[  1788.983] (II) Module rendition: vendor="X.Org Foundation"
[  1788.983]    compiled for 1.10.4, module version = 4.2.4
[  1788.983]    Module class: X.Org Video Driver
[  1788.983]    ABI class: X.Org Video Driver, version 10.0
[  1788.983] (II) LoadModule: "xgi"
[  1788.983] (II) Loading /usr/lib64/xorg/modules/drivers/xgi_drv.so
[  1788.983] (II) Module xgi: vendor="X.Org Foundation"
[  1788.983]    compiled for 1.10.4, module version = 6.1.6803
[  1788.983]    Module class: X.Org Video Driver
[  1788.983]    ABI class: X.Org Video Driver, version 10.0
[  1788.983] (II) LoadModule: "mach64"
[  1788.983] (II) Loading /usr/lib64/xorg/modules/drivers/mach64_drv.so
[  1788.983] (II) Module mach64: vendor="X.Org Foundation"
[  1788.983]    compiled for 1.10.4, module version = 6.9.0
[  1788.983]    Module class: X.Org Video Driver
[  1788.984]    ABI class: X.Org Video Driver, version 10.0
[  1788.984] (II) LoadModule: "nouveau"
[  1788.984] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[  1788.984] (II) Module nouveau: vendor="X.Org Foundation"
[  1788.984]    compiled for 1.10.4, module version = 0.0.16
[  1788.984]    Module class: X.Org Video Driver
[  1788.984]    ABI class: X.Org Video Driver, version 10.0
[  1788.984] (II) LoadModule: "intel"
[  1788.984] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[  1788.985] (II) Module intel: vendor="X.Org Foundation"
[  1788.985]    compiled for 1.10.4, module version = 2.16.0
[  1788.985]    Module class: X.Org Video Driver
[  1788.985]    ABI class: X.Org Video Driver, version 10.0
[  1788.985] (II) LoadModule: "tdfx"
[  1788.985] (II) Loading /usr/lib64/xorg/modules/drivers/tdfx_drv.so
[  1788.985] (II) Module tdfx: vendor="X.Org Foundation"
[  1788.985]    compiled for 1.10.4, module version = 1.4.3
[  1788.985]    Module class: X.Org Video Driver
[  1788.985]    ABI class: X.Org Video Driver, version 10.0
[  1788.985] (II) LoadModule: "cirrus"
[  1788.985] (II) Loading /usr/lib64/xorg/modules/drivers/cirrus_drv.so
[  1788.985] (II) Module cirrus: vendor="X.Org Foundation"
[  1788.985]    compiled for 1.10.4, module version = 1.3.2
[  1788.985]    Module class: X.Org Video Driver
[  1788.985]    ABI class: X.Org Video Driver, version 10.0
[  1788.985] (II) LoadModule: "radeon"
[  1788.986] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[  1788.986] (II) Module radeon: vendor="X.Org Foundation"
[  1788.986]    compiled for 1.10.4, module version = 6.14.2
[  1788.986]    Module class: X.Org Video Driver
[  1788.986]    ABI class: X.Org Video Driver, version 10.0
[  1788.986] (II) LoadModule: "vmwlegacy"
[  1788.986] (II) Loading /usr/lib64/xorg/modules/drivers/vmwlegacy_drv.so
[  1788.986] (II) Module vmwlegacy: vendor="X.Org Foundation"
[  1788.986]    compiled for 1.10.4, module version = 11.0.3
[  1788.986]    Module class: X.Org Video Driver
[  1788.986]    ABI class: X.Org Video Driver, version 10.0
[  1788.986] (II) UnloadModule: "vmwlegacy"
[  1788.986] (II) Unloading vmwlegacy
[  1788.986] (II) Failed to load module "vmwlegacy" (already loaded, 0)
[  1788.986] (II) LoadModule: "nv"
[  1788.987] (II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
[  1788.987] (II) Module nv: vendor="X.Org Foundation"
[  1788.987]    compiled for 1.10.4, module version = 2.1.18
[  1788.987]    Module class: X.Org Video Driver
[  1788.987]    ABI class: X.Org Video Driver, version 10.0
[  1788.987] (II) LoadModule: "i128"
[  1788.987] (II) Loading /usr/lib64/xorg/modules/drivers/i128_drv.so
[  1788.987] (II) Module i128: vendor="X.Org Foundation"
[  1788.987]    compiled for 1.10.4, module version = 1.3.4
[  1788.987]    Module class: X.Org Video Driver
[  1788.987]    ABI class: X.Org Video Driver, version 10.0
[  1788.987] (II) LoadModule: "mga"
[  1788.987] (II) Loading /usr/lib64/xorg/modules/drivers/mga_drv.so
[  1788.987] (II) Module mga: vendor="X.Org Foundation"
[  1788.987]    compiled for 1.10.4, module version = 1.4.13
[  1788.987]    Module class: X.Org Video Driver
[  1788.988]    ABI class: X.Org Video Driver, version 10.0
[  1788.988] (II) LoadModule: "siliconmotion"
[  1788.988] (II) Loading /usr/lib64/xorg/modules/drivers/siliconmotion_drv.so
[  1788.988] (II) Module siliconmotion: vendor="X.Org Foundation"
[  1788.988]    compiled for 1.10.4, module version = 1.7.5
[  1788.988]    Module class: X.Org Video Driver
[  1788.988]    ABI class: X.Org Video Driver, version 10.0
[  1788.988] (II) LoadModule: "openchrome"
[  1788.988] (II) Loading /usr/lib64/xorg/modules/drivers/openchrome_drv.so
[  1788.988] (II) Module openchrome: vendor="http://openchrome.org/"
[  1788.988]    compiled for 1.10.4, module version = 0.2.904
[  1788.988]    Module class: X.Org Video Driver
[  1788.988]    ABI class: X.Org Video Driver, version 10.0
[  1788.988] (II) LoadModule: "dummy"
[  1788.989] (II) Loading /usr/lib64/xorg/modules/drivers/dummy_drv.so
[  1788.989] (II) Module dummy: vendor="X.Org Foundation"
[  1788.989]    compiled for 1.10.4, module version = 0.3.4
[  1788.989]    Module class: X.Org Video Driver
[  1788.989]    ABI class: X.Org Video Driver, version 10.0
[  1788.989] (II) LoadModule: "v4l"
[  1788.989] (II) Loading /usr/lib64/xorg/modules/drivers/v4l_drv.so
[  1788.989] (II) Module v4l: vendor="X.Org Foundation"
[  1788.989]    compiled for 1.10.4, module version = 0.1.1
[  1788.989]    ABI class: X.Org Video Driver, version 10.0
[  1788.989] (II) LoadModule: "r128"
[  1788.990] (II) Loading /usr/lib64/xorg/modules/drivers/r128_drv.so
[  1788.990] (II) Module r128: vendor="X.Org Foundation"
[  1788.990]    compiled for 1.10.4, module version = 6.8.1
[  1788.990]    Module class: X.Org Video Driver
[  1788.990]    ABI class: X.Org Video Driver, version 10.0
[  1788.990] (II) LoadModule: "qxl"
[  1788.990] (II) Loading /usr/lib64/xorg/modules/drivers/qxl_drv.so
[  1788.990] (II) Module qxl: vendor="X.Org Foundation"
[  1788.990]    compiled for 1.10.4, module version = 0.0.0
[  1788.990]    Module class: X.Org Video Driver
[  1788.990]    ABI class: X.Org Video Driver, version 10.0
[  1788.990] (II) LoadModule: "s3virge"
[  1788.990] (II) Loading /usr/lib64/xorg/modules/drivers/s3virge_drv.so
[  1788.991] (II) Module s3virge: vendor="X.Org Foundation"
[  1788.991]    compiled for 1.10.4, module version = 1.10.4
[  1788.991]    Module class: X.Org Video Driver
[  1788.991]    ABI class: X.Org Video Driver, version 10.0
[  1788.991] (II) LoadModule: "fbdev"
[  1788.991] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[  1788.991] (II) Module fbdev: vendor="X.Org Foundation"
[  1788.991]    compiled for 1.10.4, module version = 0.4.2
[  1788.991]    ABI class: X.Org Video Driver, version 10.0
[  1788.991] (II) LoadModule: "vesa"
[  1788.991] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[  1788.991] (II) Module vesa: vendor="X.Org Foundation"
[  1788.991]    compiled for 1.10.4, module version = 2.3.0
[  1788.991]    Module class: X.Org Video Driver
[  1788.991]    ABI class: X.Org Video Driver, version 10.0
[  1788.991] (WW) Falling back to old probe method for sisusb
[  1788.991] (WW) Falling back to old probe method for ast
[  1788.991] (WW) Falling back to old probe method for i740
[  1788.991] (WW) Falling back to old probe method for voodoo
[  1788.991] (WW) Falling back to old probe method for apm
[  1788.991] (WW) Falling back to old probe method for sis
[  1788.991] (WW) Falling back to old probe method for trident
[  1788.991] (WW) Falling back to old probe method for glint
[  1788.991] (WW) Falling back to old probe method for cirrus
[  1788.991] (II) Loading sub module "cirrus_laguna"
[  1788.991] (II) LoadModule: "cirrus_laguna"
[  1788.992] (II) Loading /usr/lib64/xorg/modules/drivers/cirrus_laguna.so
[  1788.992] (II) Module cirrus_laguna: vendor="X.Org Foundation"
[  1788.992]    compiled for 1.10.4, module version = 1.0.0
[  1788.992]    ABI class: X.Org Video Driver, version 10.0
[  1788.992] (II) Loading sub module "cirrus_alpine"
[  1788.992] (II) LoadModule: "cirrus_alpine"
[  1788.992] (II) Loading /usr/lib64/xorg/modules/drivers/cirrus_alpine.so
[  1788.992] (II) Module cirrus_alpine: vendor="X.Org Foundation"
[  1788.992]    compiled for 1.10.4, module version = 1.0.0
[  1788.992]    ABI class: X.Org Video Driver, version 10.0
[  1788.992] (WW) Falling back to old probe method for i128
[  1788.992] (WW) Falling back to old probe method for siliconmotion
[  1788.992] (WW) Falling back to old probe method for dummy
[  1788.992] (WW) Falling back to old probe method for v4l
[  1788.992] (II) v4l driver for Video4Linux
[  1788.992] (WW) Falling back to old probe method for s3virge
[  1788.992] (II) FBDEV: driver for framebuffer: fbdev
[  1788.992] (II) VESA: driver for VESA chipsets: vesa
[  1788.993] (++) Using config file: "/root/xorg.conf.new"
[  1789.000] (==) ServerLayout "X.org Configured"
[  1789.000] (**) |-->Screen "Screen0" (0)
[  1789.000] (**) |   |-->Monitor "Monitor0"
[  1789.000] (**) |   |-->Device "Card0"
[  1789.000] (**) |-->Screen "Screen1" (1)
[  1789.000] (**) |   |-->Monitor "Monitor1"
[  1789.000] (**) |   |-->Device "Card1"
[  1789.000] (**) |-->Input Device "Mouse0"
[  1789.000] (**) |-->Input Device "Keyboard0"
[  1789.000] (==) Automatically adding devices
[  1789.000] (==) Automatically enabling devices
[  1789.000] (**) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins,
    catalogue:/etc/X11/fontpath.d,
    built-ins
[  1789.000] (**) ModulePath set to "/usr/lib64/xorg/modules"
[  1789.000] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1789.000] (WW) Disabling Mouse0
[  1789.000] (WW) Disabling Keyboard0
[  1789.000] (II) Loading sub module "fbdevhw"
[  1789.000] (II) LoadModule: "fbdevhw"
[  1789.001] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[  1789.001] (II) Module fbdevhw: vendor="X.Org Foundation"
[  1789.001]    compiled for 1.10.6, module version = 0.0.2
[  1789.001]    ABI class: X.Org Video Driver, version 10.0
[  1789.001] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[  1789.001] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[  1789.004] (EE) open /dev/fb0: No such device
[  1789.008] (WW) Falling back to old probe method for fbdev
[  1789.008] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[  1789.008] 
Backtrace:
[  1789.017] 0: X (xorg_backtrace+0x28) [0x458908]
[  1789.021] 1: X (0x400000+0x5f629) [0x45f629]
[  1789.029] 2: /lib64/libpthread.so.0 (0x311f800000+0xf500) [0x311f80f500]
[  1789.034] Segmentation fault at address (nil)
[  1789.038] 
Fatal server error:
[  1789.047] Caught signal 11 (Segmentation fault). Server aborting
[  1789.052] 
[  1789.056] 
Please consult the CentOS support 
     at https://www.redhat.com/apps/support/
 for help. 
[  1789.078] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1789.082] 
share|improve this question
    
just to update, I reinstalled a new guest Centos 6.3 VM (on the same Hyper-V node) this time with Desktop (as opposed to the minimal install last time) - Gnome desktop works without any intervention. /dev/fb0 is available on this guest. I would still like to post-mortem the above and work out how I can get it working to help improve my knowledge - therefore this must be a config issue. –  g18c Jan 12 '13 at 19:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.