Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using pfSense 2.0.2 and want to set up a failover between my normal WAN connection (GW_WAN) and a 3G surfstick (GW_OPT8). I put both in a gateway group called WAN_FAILOVER:

GW_WAN  Tier1 (Monitor IP 8.8.4.4)
GW_OPT8 Tier2 (Monitor IP 8.8.8.8)

Trigger level is member down.

Additionally I enabled "Allow default gateway switching" in System - Advanced - Miscellaneous. In the firewall rules on the VLAN interface where my compuster is connected to, I have set the WAN_FAILOVER group as gateway.

For testing the failover I removed the WAN (GW_WAN) ethernet cable. System log then looks like this:

Jan 12 19:42:32     php: : MONITOR: GW_WAN is down, removing from routing group
Jan 12 19:42:32     php: : Default gateway down setting GW_OPT8 as default!
Jan 12 19:42:19     apinger: ALARM: GW_WAN(8.8.4.4) *** down ***

Routing table also gets updated:

default     10.64.64.0  UGS     0   184     1492    ppp0

Any idea why it isn't working? Thanks!

share|improve this question

1 Answer 1

I meanwhile foudn the error: On Firewall: NAT: Outbound the manual rule creation was enabled (needed e.g. if one wants static ports, useful for VoIP). There I only had rules for the normal WAN interface, duplicating those rules and replacing the WAN interface with the failover interface made everything work :-) Also one doesn't need the gateway group and WAN_FAILOVER group as gateway in the firewall rules when having only 2 WAN interfaces. I guess those options are for more advanced things, e.g. 3 WAN interfaces where it isn't clear which one shall be used when the primary one fails.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.