Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a problem with the mstsc on one machine - it cannot connect to remote servers. I tried to uninstall it - I boot in safe mode, delete everything that was connected any way with this software (including the library msctax) in system32 and dllcache, I deleted everything containing mstsc in the registry, and when i tried to install the mstsc from the packet i downloaded from microsoft.com, it stopped and showed me an error that Mstsc is installed on my computer, and the installation was unsiccesfull.

Any ideas anyone about solving this ?

share|improve this question
1  
Tried the Windows Installer Cleanup Utility? It's designed for exactly this kind of thing. support.microsoft.com/kb/290301 –  Darth Melkor Jul 27 '09 at 19:25

7 Answers 7

The fix is simple.

Go to the following link. http://www.microsoft.com/downloads/en/details.aspx?FamilyId=72158b4e-b527-45e4-af24-d02938a95683&displaylang=en

Install RDP 7. It includes full compatibility with Windows 7 and 2008R2.

share|improve this answer

You can either copy the files manually or patch the msi package using Orca.

Orca.exe is a database table editor for creating and editing Windows Installer packages and merge modules. The tool provides a graphical interface for validation, highlighting the particular entries where validation errors or warnings occur.

This tool is only available in the Windows SDK Components for Windows Installer Developers. It is provided as an Orca.msi file. After installing the Windows SDK Components for Windows Installer Developers, double click Orca.msi to install the Orca.exe file.

Basically you'll have to mimic the msi package behaviour: change the default files and re-register the component. There are four files for the RDC client 6.0:

  • system32/mstsc.exe
  • system32/mstscax.dll
  • system32/us-en/mstsc.exe.mui
  • system32/us-en/mstscax.dll.mui

You may have to change the localized folder (us-en). The folder should already exist. I have a localized version.

Extract the files from the list above using 7-ZIP from the RDP client packages. You first must unregister the DLL, delete the files, copy the new files to their location and register the new DLL.

Unregister the mstsc components using this command:

regsvr32 /u mstscax.dll

And register it with

regsvr32 /i mstscax.dll
share|improve this answer

If you haven't tried already:

If you have system restore enabled, I have had good luck with that. I am sure you know this, but going to say it anyways, reinstalling Windows is often faster then fixing Windows -- although you of course will learn less.

share|improve this answer

You could install VNC OK it won't fix treminal services but it a work around for remote access.

share|improve this answer

that sounds rough. something was have been corrupted. unexpected system shutdown maybe or a previous virus cleaned from the system?

I'd probably try a 3rd party terminal service in the meantime until you had the available time and resources to restore or rebuild that machine.

RoyalTS is a decent 3rd party terminal server, not sure if it piggybacks off of the mstsc executables though.

share|improve this answer

I'd be very interested in hearing what symptoms you were getting when you were originally failing to connect, before you tried reinstalling. There are a few things I am aware of that can cause this to happen, and I know of fixes, but I really need more info first.

Edit: for what it's worth, if the problem turns out to be server-side, doing client-side jiggery pokery will get you nowhere, of course.

share|improve this answer

One thing I've tried is to use the sysinternals tools...process monitor in particular...to monitor the installation and running programs to see if anything is getting an access denied error to a particular registry key or folder on the system. I haven't seen the issue you are having in particular, but this technique has helped me a number of times.

Can't hurt to try it, those utilities are free to download.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.