Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

sorry if this has been answered already, but my searches brought me to nowhere.

I have just installed LAMP environment on Amazon EC2 instance. It runs on:

Ubuntu precise 12.04 amd64 server
PHP Version 5.3.10-1ubuntu3.4
MySQL 5.5.28
Apache/2.2.22 (Ubuntu)
Drupal 7-18

Drupal installation tells me that I have not GD enabled and PDO extension are disabled. However, looking at phpinfo() I have :

GD Support  enabled
GD Version  2.0
FreeType Support    enabled
FreeType Linkage    with freetype
FreeType Version    2.4.8
T1Lib Support   enabled
GIF Read Support    enabled
GIF Create Support  enabled
JPEG Support    enabled
libJPEG Version unknown
PNG Support enabled
libPNG Version  1.2.46
WBMP Support    enabled

Directive   Local Value Master Value
gd.jpeg_ignore_warning  0   0

and

PDO

PDO support enabled
PDO drivers mysql

pdo_mysql

PDO Driver for MySQL    enabled
Client API version  5.5.28

Directive   Local Value Master Value
pdo_mysql.default_socket    /var/run/mysqld/mysqld.sock /var/run/mysqld/mysqld.sock

So, in theory everything must work, why does Drupal not recognize them? I haven't changed anything at all from the clean install of LAMP. May I be missing something then?

Thanks in advance, maxim

share|improve this question

1 Answer 1

For some reason this was solved by reinstalling:

sudo apt-get install --reinstall php5-gd php5-mysql
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.