Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Followin this guide http://www.servethehome.com/supermicro-x8si6-f-motherboard-review-including-onboard-lsi-sas-2008-controller/ I got myself an RPC 4224 case (They are called Inter-Tech in Europe, but are the same) and an Supermicro X8SI6-F with the onboard LSI SAS 2008 Controller along with an HP SAS expander card.

After assembling everything I am able to access the Motherboards BIOS and the controllers BIOS.

However I do not see any of my 24 3-TB Seagate drives showing in either my OS (Ubuntu server 12.10), the Motherboard BIOS or the RAID Controller BIOS.

Also I cannot find any functionality in the Controller BIOS where I can put it on JBOD.

The hardware should be compatible, I found various posts about this contorller and the HP SAS Expander card.

I would like to have the drives accessible as JBOD in my OS. (No hardware raid of any kind...)

Could someone point me in the right direction for troubleshooting? Any help is appriciated!

I mounted the HP SAS expander card on the x8 slot and not the x16 slot.

It is as showed on the pictures of the blogpost posted above.

Supermicro webpage says that its only a x4 slot using an x8 slot. Could that be a problem? Maby it doesnt deliver enough power to the card?

I connected the expander card using two sff 8087 cables on the ports to controller as stated by the manual.

Also the HP SAS expander is recognised and displayed as type "enclosure" in the SAS Controller firmware...

I really dont know what to do :(

share|improve this question
    
Are you trying to build a ZFS system? –  ewwhite Jan 13 '13 at 23:53
    
"Supermicro webpage says that its only a x4 slot using an x8 slot." -> Should not be a problem. You can use any card out of x1/x4/x8/16 in any slot in the x1/x4/x8/16 range (though sometimes you have to use a saw to open the end of the connector. It should work though. ---------- "Not enough power" -> No, power is delivers via the same pins in all PCIe cards (and is up to 75 watt, see the wikipedia article for a pinout) –  Hennes Jan 13 '13 at 23:54
    
ok, well the port is only for power, the expander card itself does not interact with the system. i am not using a filesystem or hardware solution for spanning or striping, i am writing an application which is aware of the different drives. redudancy is across several servers. thats why i only need to mount the drives to their separate mount points. i guess you could compare it to mogilefs –  The Shurrican Jan 13 '13 at 23:59
    
What kind (IT/IR) / what LSI SAS 2008 card's firmware and BIOS versions are ? –  pdaukintis Jan 20 '13 at 18:09
    
I am currently trying to flash the firmware from IR to IT, because I figured that could be the issue. Its strange that I also do not see the directly attached drive, however I am trying to flash to IT anyway. Unfortunately it is ab it complicated because the erasing of the old firmware won't work with the linux binaries, and my DOS knowledge is limited. The tool seems to hang at every command... –  The Shurrican Jan 21 '13 at 12:41

2 Answers 2

I've used quite a few HP SAS Expander cards. The SAS card should be transparent to your setup, only showing the drives in your LSI controller's BIOS. What happens if you run fdisk -l in the OS once it's booted?

Also, please list the output of cat /proc/scsi/scsi.

share|improve this answer
    
fdisk -l shows only the system drive which si connected to the sata controller and the usb drive i booted from. i will check /proc/scsi/scsi. interesting that the controller really does recognise the hp sas expander, it displays it by name. –  The Shurrican Jan 14 '13 at 0:27
up vote 1 down vote accepted

I flashed an alternative onto the controller, this required the complete erasement of the old. This can only be done with the undocumented command sas2flsh -o -e 7.

Also only with the ms dos version of the flash utitily found on the vendors webpage.

After that the alternative "LT" firmware can be installed. Due to the complete eradication of the old firmware, including the SAS address, you have to manually re program it.

I found it on the mainboard, but I think any number would have worked as far as unique.

This can also be only done sith the dos utility and the -sasadd command.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.