Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently installed GIT 1.8.1 on my AIX 6.1 machine and am facing a few issues with it.

Now if I login as root and issue git commands like git --version I get the response as shown : Code:

git version 1.8.1

And I have tried creating repositories as root too and it works fine.

Now If I login as just a normal user and if I issue the version command : git --version I am getting the response as :

genuser:stud:/students/admin> git --version
exec(): 0509-036 Cannot load program git because of the following errors:
        0509-150   Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
        0509-152   Member libiconv.so.2 is not found in archive

Now how come its working with root user and not working with normal user.

But If I issue man git command in normal user I'm getting the manual for git but the rest of the commands give the above error.

BTW the file libiconv.so.2 is not present in /usr/lib directory but it still works in root user but not in normal user.

How can I fix this.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Sounds like a LIBPATH issue, compare root's LIBPATH with the LIBPATH of the user you're trying to run git as.

share|improve this answer
    
Yes its different.How can I modify the LIBPATH variable of genral users to include the path vaiable of the root user. –  david.colais Jan 14 '13 at 11:28
    
Changed the libpath no effect.Still getting the same error. –  david.colais Jan 14 '13 at 11:35
    
I found a similar thread having the same issue but do not know how to apply the fix suggested zabbix.com/forum/showthread.php?t=24838 Any idea how to apply this fix. –  david.colais Jan 14 '13 at 11:40
    
Did not set the LIBPATH properly now it works.Thanks a lot. –  david.colais Jan 14 '13 at 12:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.