Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have built a freenas based NAS. It's configured correctly, but how i force windows to automount on login with specific credentials?

share|improve this question

closed as off topic by Dan, Helvick, Chris S Jan 14 '13 at 13:48

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

enter image description here

"Connect using different credentials.."

You have done a very simple Google search for this.

share|improve this answer

In my answer I'm assuming that you want to mount that as a network drive as drive M:

Open a command prompt (start -> run -> cmd.exe) and Issue the followin command:

net use M: \\%SERVER%\%SHARENAME% /USER:%USER% %PASSWORD% /PERSISTENT:YES

Make sure to replace the %SERVER%, %SHARENAME%, %USER% and %PASSWORD% with the correct values.

This will cause the M: drive to be mounted upon login.

The other option, is to write a simple batch script to test if it's mounted, if not, remount. If you need a script example - let me know.

Note that if you script this, you'll need to provide the password in the batch file or use Credentials Manager.

Hope that works for you (under the assumption I made) Idan.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.