Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are using mstsc to replace explorer.exe on our thin clients. Everything works as intended except usb redirection. We have a USB device plugged into the thin client (thumbprint device). If I go into an explorer.exe desktop and run rdp manually from the desktop on the thin client it works like a dream, however, if I turn back on the script that runs a remote rdp file in place of explorer.exe on logon it does not appear to work correctly. Any thoughts on this?

UPDATE: It appears to be an issue with an ActiveX control that needs registered by user on the thin client. I am at this time trying to figure out how to "auto-register" this damn thing on the local thin clients.

share|improve this question
Take note of any differences in what Windows services are running when explorer.exe is launched normally, and when explorer.exe is not launched. Certain Windows services, such as "Windows Biometric Service," are set to manual by default. The Explorer shell may be capable of starting such manual services on demand, whereas mstsc.exe may not be. UPnP Device Host is also manual by default. Human Interface Device Access service is manual. Setting those services to Automatic might help. – Ryan Ries Jan 14 '13 at 18:01
I will check all of these thanks for your input. I have noticed I am getting an Event ID 36 on the servers that say a Policy is not allowing other PnP devices to be redirected. However, I can't find a single policy that is blocking this. I will post back on the services changes and see if that makes a difference. – Levi Jan 14 '13 at 18:53
I set the following services to automatic: UPnP Device Host Windows Biometric Service Human Interface Devices Access Biometric Authentication Services This was all set on the thin client - so far no changes - and it appears that the error has stopped on the servers. I am doing more testing to see why the error stopped yet I still can't connect the device up. – Levi Jan 14 '13 at 19:02
Well those policy settings are here, , but I don't think policy settings are your problem since it works when Explorer is loaded normally. – Ryan Ries Jan 14 '13 at 19:07
Also do you have something like devicestoredirect:s:* in your RDP file? – Ryan Ries Jan 14 '13 at 19:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.