Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Trying to install postfix from ports and get this error:

===>   Compressing manual pages for cyrus-sasl-2.1.26_2
===>   Running ldconfig
/sbin/ldconfig -m /usr/local/lib
===>   Registering installation for cyrus-sasl-2.1.26_2
===>   Returning to build of postfix-2.9.4_2,1
Error: shared library "sasl2.2" does not exist
*** Error code 1

Stop in /usr/ports/mail/postfix.
*** Error code 1

Stop in /usr/ports/mail/postfix.
*** Error code 1

Stop in /usr/ports/mail/postfix.
ldconfig -r | grep sasl
[/usr/ports/mail/postfix] [12:49] [pts/0] 
    111:-lsasl2.3 => /usr/local/lib/libsasl2.so.3
    297:-lsasldb.2 => /usr/local/lib/compat/pkg/libsasldb.so.2
    312:-lsasl2.2 => /usr/local/lib/compat/pkg/libsasl2.so.2
    318:-lsasldb.3 => /usr/local/lib/compat/pkg/libsasldb.so.3
share|improve this question
    
...and ? Did you want to build postfix with Cyrus SASL support ? –  adaptr Jan 15 '13 at 9:06
    
Yes, i want to build it with Cyrus SASL support. –  Klipach Jan 15 '13 at 9:13
    
As the above result clearly shows, postfix expects cyrus-sasl >= 2.2; you have installed 2.1. –  adaptr Jan 15 '13 at 9:21
    
Ok, so how can i install postfix 2.9 via FreeBSD ports? Or it is a port bug? I also trie to install postfix 2.8 (from ports) and got the same error. –  Klipach Jan 15 '13 at 9:25
    
Also i tried postfix 2.6 and 2.7 and got the same error –  Klipach Jan 15 '13 at 9:38

1 Answer 1

Please make sure you have run portsnap fetch update before. Afterwards upgrade the ports which are not up to date anymore by using pkg_version -l "<".

This should solve your issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.