Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I do a yum list httpd I get the following version returned:

httpd.x86_64 1:2.2.22-12053112

When I try to do a yum install httpd-devel I get dependency errors like this:

httpd-devel-2.2.3-65.el5.centos.3.x86_64 from updates has depsolving problems
  --> Missing Dependency: httpd = 2.2.3-65.el5.centos.3 is needed by package httpd-devel-2.2.3-65.el5.centos.3.x86_64 (updates)
Error: Missing Dependency: httpd = 2.2.3-65.el5.centos.3 is needed by package httpd-devel-2.2.3-65.el5.centos.3.x86_64 (updates)

How can I determine what packages I need to install?

This is on a mediatemple DV 4.

Here is the output of yum repolist:

Loaded plugins: fastestmirror
Determining fastest mirrors
 * base: mirrors.lga7.us.voxel.net
 * extras: mirrors.lga7.us.voxel.net
 * updates: mirror.atlanticmetro.net
base                                                     | 1.1 kB     00:00     
base/primary                                             | 1.2 MB     00:00     
base                                                                  3591/3591
extras                                                   | 2.1 kB     00:00     
extras/primary_db                                        | 207 kB     00:00     
updates                                                  | 1.9 kB     00:00     
updates/primary_db                                       | 1.0 MB     00:00     
repo id                        repo name                                  status
base                           CentOS-5 - Base                            3,591
extras                         CentOS-5 - Extras                            279
updates                        CentOS-5 - Updates                         1,215

Update:

I think I made some progress on this. I found this on the plesk forum since mediatemple dv's run plesk.

I made a repository file in /etc/yum.repo.d/ with the following contents.

[Plesk-Apache]
name=Plesk Apache
baseurl=http://autoinstall.plesk.com/APACHE_2.2.21/dist-rpm-CentOS-5-x86_64/
enabled=1
share|improve this question
1  
Please run yum repolist and post the output. –  ewwhite Jan 15 '13 at 13:35

1 Answer 1

You've installed a third party repository webtatic and the error complains of a missing package from that repository.

Sometimes this happens when your local cache gets out of sync with the state of the repository, and in that case you can just

yum clean all

and try again.

If that doesn't solve the problem, then you should contact the maintainer of the third party repository to report the problem.

share|improve this answer
    
I ran the command above and then ran yum install httpd-devel got more missing dependency errors. I installed the webtatic after not having any luck with the default repositories. Going to do a clean install of the VM and start over. –  user429699 Jan 15 '13 at 20:02
    
Ok, I reverted the VM to it's original state and updated the post above with appropriate responses I got after doing so. –  user429699 Jan 15 '13 at 20:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.