Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my file server I ended up growing the RAID (5) and then I went ahead and deleted and remade the partition holding the XFS filesystem. I used Parted to do this.

After parted ran I tried to mount the filesystem but it failed with a bad superblock.

I ran xfs_repair and no such luck, it just skips to the secondary superblock and scans and scans. I'm currently letting gpart run, hopefully it finds something.

Long story short, is there anyway to rebuild the XFS superblock? It was overwritten with a GPT partition table header.

The server is running Arch 64 fully updated. Its a 3TB array of 4 disks in RAID 5.

Thank you!

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.