Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Whenever I try to login into my Windows 2011 server through remote desktop connection on a Windows XP computer I am unable to. Whenever I attempt to, it tries to "sync" for a while, and then displays a message 'unable to connect'. Does anyone know how to fix this so I can log into my server through XP computers. Is there any settings on the server I need to change?

share|improve this question

closed as not constructive by joeqwerty, mdpc, Alex, Ward, MadHatter Jan 16 '13 at 7:14

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You're not including enough information. Is this server on the same LAN as you? Are you sure RDP is configured properly on the server? Have you considered Firewall rules blocking your connection? –  mossy Jan 16 '13 at 1:49
    
Yes, the server is on the same LAN. I have also checked the Firewall connection, and tried it with all rules unblocked, and it still fails to work... & no I haven't checked that. Where can I check the RDP? –  user154618 Jan 16 '13 at 1:54
    
my computer -> (advanced)properties -> remote. –  mossy Jan 16 '13 at 1:56

1 Answer 1

Check your Remote Desktop Settings on the server and see if you are using the setting Allow connections from computers running any version of Remote Desktop (less secure) or if the default setting of Allow connections only from computer running Remote Desktop with network Level Authentication (more secure)

If you don't have the updated Remote Desktop client installed the more secure option won't allow a Windows XP host to connect.

I only have access to a Windows 2008 server at my current location so your interface may be different to that pictured.

Remote Desktop setting

Forgot to mention that you may also need to perform the following on your XP client (I have it set up by default via group policy in my XP boxes.)

To enable NLA in XP machines; first install XP SP3, then edit the registry settings on the XP client machine to allow NLA

• Configure Network Level Authentication

  1. Click Start, click Run, type regedit, and then press ENTER.
  2. In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. In the details pane, right-click Security Packages, and then click Modify.
  4. In the Value data box, type tspkg. Leave any data that is specific to other SSPs, and then click OK.
  5. In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders
  6. In the details pane, right-click SecurityProviders, and then click Modify.
  7. In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
  8. Exit Registry Editor.
  9. Restart the computer. (Note, you may not need to reboot - just my established practice (as well as backing up any key before modification...))
share|improve this answer
    
PERFECT! thank you so much for your help. It now works :D –  user154618 Jan 16 '13 at 3:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.