Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Pulling my hair out. PHP built from source, everything working. Now need to install imagick and can't get it installed.

I am running Debian on kernel 3.7.1 with PHP 5.3.20 (the last version my app supports, cannot go to PHP 5.4).

pecl install imagick
...
checking ImageMagick MagickWand API configuration program... found in /usr/bin/Wand-config
checking if ImageMagick version is at least 6.2.4... configure: error: no. You need at least Imagemagick version 6.2.4 to use Imagick.
ERROR: `/tmp/pear/temp/imagick/configure --with-imagick' failed

Yet, I have version 6.7.7 installed:

# convert --version
Version: ImageMagick 6.7.7-10 2012-11-06 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC
Features: OpenMP

I also tried installing the latest beta (pecl install imagick-beta), same result. Also tried an old version 2.3.0, same result. Also tried downloading source, phpize, and configure -- same result.

Can someone help please?

share|improve this question
    
What returns MagickWand-config --version command? –  hangover Jan 16 '13 at 9:47
    
Another guess: in Debian, binary MagickWand-config is a part of libmagickwand-dev package. Is this package installed in your system? –  hangover Jan 16 '13 at 10:01

2 Answers 2

I was finally able to solve this myself. I ended up doing:

apt-get remove graphicsmagick-libmagick-dev-compat imagemagick imagemagick-common
apt-get autoremove

Then:

apt-get install libmagickwand-dev

And finally was able to get imagick installed via pecl without error:

pecl install imagick-beta
share|improve this answer

Best solution to solve this problem is installing Imagemagick-Devel package.

In RHEL based OSes you can run this command:

yum install ImageMagick-devel

For Debian systems:

sudo apt-get install libmagickwand-dev imagemagick libmagickcore-dev
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.