Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 10 clients and one server syncing with 2 NTP servers on windows using Meinberg NTP, all of them running Windows XP SP3. Except the server all of them syncing their time perfectly. The one that is losing its sync is running SQL server 2008, filezilla and NUUO surveillance system. On this system NTP offset is growing every time it polls from servers until it becomes out of sync after two days. Then I should restart NTP server or reboot the whole system. My NTP configuration is simple:

server  127.127.1.0 minpoll 4
fudge   127.127.1.0 stratum 10

server 192.168.1.102 minpoll 4 burst prefer
server 192.168.1.220 minpoll 4 burst prefer 

This configuration is used on other clients. 192.168.1.102 and 192.168.1.220 are syncing their time with internet. All of the clients are on wireless LAN(server and two NTP servers are on physical gigabit LAN). Can anyone suggest what is causing problem?

[UPDATE]

ntpdc -c sysinfo output:

system peer:          192.168.1.102
system peer mode:     client
leap indicator:       11
stratum:              4
precision:            -20
root distance:        0.41095 s
root dispersion:      1.90089 s
reference ID:         [192.168.1.102]
reference time:       d4a0ce3c.13374d75  Wed, Jan 16 2013 10:29:08.075
system flags:         auth monitor ntp kernel stats
jitter:               0.503342 s
stability:            0.000 ppm
broadcastdelay:       0.000000 s
authdelay:            0.000000 s

ntpdc -p output:

     remote           local      st poll reach  delay   offset    disp
=======================================================================
=LOCAL(1)        127.0.0.1       10   16    0 0.00000  0.000000 3.96863
=192.168.1.220   192.168.1.5      2   16  377 0.00017  2.088162 0.01524
*192.168.1.102   192.168.1.5      3   16  373 0.02069  2.065532 0.01714
share|improve this question
    
Check ntpdc -p and ntpdc -c sysinfo outputs. –  David Schwartz Jan 16 '13 at 6:33
    
@DavidSchwartz See the update –  Majid Azimi Jan 16 '13 at 7:07
1  
Make sure you have no other kind of time synchronization in use on the server. Also, are you using any kind of virtualization? –  David Schwartz Jan 16 '13 at 8:12
    
@DavidSchwartz I do not use virtualization. Also I have disabled Windows Time Service. How can I know If there is another time source? –  Majid Azimi Jan 16 '13 at 12:58

1 Answer 1

Without more information it is hard to give a full answer. Can you post the full ntp.conf for the broken server? And post a list of the offset showing the growth over time?

I am not sure why you have both remote machines set as prefer?

There are some things you can do to improve the setup:

For starters you should remove the LOCAL reference clock entry:

server  127.127.1.0 minpoll 4
fudge   127.127.1.0 stratum 10

Next you should remove the burst entries and change them to iburst. See the ntp docs on burst for more information.

Finally you really need to have three sources. A man with one watch knows what time it is, a man with two watches is never sure. By adding a third time server your clients will be able to break the tie if the two servers disagree about the time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.