Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have an IIS site with an application.

The application points to a physical path on the C drive.

In the "Connect As" settings "Application user (pass-through authentication)" is selected.

The user that I am logged in as has full control of the directory and no problem viewing the directory in windows explorer.

When I try to browse I get a 401 error, if I give "Everyone" access to the directory it works fine.

How do I get IIS to use my credentials, or some configured credentials to browse the directory?

share|improve this question
    
Do you have Windows authentication enabled? If you use Anonymous Authentication your Windows users are not passed through and the Application Pool identity is used to access the directory. –  Peter Hahndorf Jan 17 '13 at 18:41

1 Answer 1

Normally it is the Network Service account. Check the account the app pool is configured with. You can also create a new App Pool and configure it to use any account on the local system. Finally you'll want to allow that account to have read permissions on the folder with the files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.