Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a RHEL 6.3 server that has IPv6 disabled. If I enter ifconfig I get the following:

eth0      Link encap:Ethernet  HWaddr 00:50:56:9F:0F:61  
          inet addr:10.3.72.76  Bcast:10.3.75.255  Mask:255.255.252.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1708252 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27566 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:409249072 (390.2 MiB)  TX bytes:4583283 (4.3 MiB)

My problem is that this lack of IPv6 caused our product to fail and I want to be able to reproduce this situation for a test case (so we don't fail this way in the future). Unfortunately, I have no idea how IPv6 was disabled.

One way I know that disables IPv6 is to set NETWORKING_IPV6 and IPV6INIT to false in the /etc/sysconfig/network file. This has not been done:

[root@foo bin]# cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=foo.ds.net

The other way I know is to disable the ipv6 module. However, this also has not been done:

[root@foo bin]# lsmod | grep ipv6
ipv6                  322541  0 

I would like to reproduce this situation as closely as possible but I have no idea what has been done to this server to disable IPv6. Does anyone have any ideas?

share|improve this question
    
Have you tried to contact Red Hat Support, or looked in the knowledge base? –  Red Tux Jan 17 '13 at 16:41

2 Answers 2

up vote 3 down vote accepted

My first guess would be some /etc/sysctl* settings, some script changing /proc/sys/net/ipv6/* or something like that in /etc/rc.local but it's hard to give an anwer as there are so many places where it could be done.

share|improve this answer
1  
I mentioned the /etc/sysctl setting to the person that setup the server and that rang a bell. They found a bunch of sysctl settings they had modified but had since forgotten about. –  Pace Jan 18 '13 at 19:46
    
Some combination of net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1 presumably. –  Steve-o Feb 1 '13 at 14:56

There is a good answer, but I'll add my other scenario just in case: There is a bug in older versions of ifconfig which makes it stop showing ipv6 addresses when you have complex interface names. Use

ip -6 addr ls

to be sure of assigned IPv6 addresses.

share|improve this answer
    
Thanks, this is good to know. –  Pace Jan 22 '13 at 13:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.