Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Amazon Ec2 :: Redhat 6. 64 Bit I'm trying to follow the socks5 guidelines (http://www.catonmat.net/blog/linux-socks5-proxy/ ) to open a socks on one of our servers but unfortunately I got suck at step 1 .

ssh -N -D 0.0.0.0:1080 localhost

I get error

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
How do I fix it ?

More debug info

ssh -v -f -N -D 0.0.0.0:1080 localhost

OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'localhost' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic
debug1: Next authentication method: gssapi-keyex
debug1: No valid Key exchange context
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_0' not found

debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_0' not found

debug1: Unspecified GSS failure.  Minor code may provide more information

debug1: Unspecified GSS failure.  Minor code may provide more information

debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: No more authentication methods to try.
Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
share|improve this question
1  
Add the -d flag to get more information. –  ott-- Jan 17 '13 at 19:45
    
Put the -d to the front of the options. –  ott-- Jan 17 '13 at 19:54
    
check for firewall/permissions. I think your firewall preventing it. –  alexus Jan 17 '13 at 19:55
    
alexus selinux is disabled. Btw the server provider is Amazon AWS –  user1963938 Jan 17 '13 at 20:07
    
What ott probably means to say is -v for VERBOSE output. Edit your question and add the verbose output. –  Zoredache Jan 17 '13 at 20:37

3 Answers 3

SSH at EC2 doesn't allow connecting without ssh key (password login are denied, even to localhost).e.g. ssh -i mykey.pem -N -D 0.0.0.0:1080 localhost

share|improve this answer

ssh looks for the private key file named id_rsa and it doesn't find it. It's possible that you used ssh-keygen to generate the key pair and gave the files another name. If this is the case, try to rename those files to id_rsa and id_rsa.pub, or try

ssh -v -i private_key_file_name -f -N -D 0.0.0.0:1080 localhost
share|improve this answer

check for permissions and ownership on the server:

  • home
  • .ssh dir
  • authorized_keys
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.