Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use dhcrealy on a CentOs 5 kernel which have kernel version 3.5.3.

I configured /etc/sysconfig/dhcrelay file like that

dhcrelay -i eth1

While dhcrealy is stopped, I run /etc/init.d/dhcrelay status and I get this output.

Internet Systems Consortium DHCP Relay Agent V3.0.5-RedHat
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit
Listening on LPF/eth1/08:00:27:49:5e:e7
Sending on   LPF/eth1/08:00:27:49:5e:e7
Sending on   Socket/fallback
dhcrelay (pid 27536) is running...

Then I check ps aux | grep dhcrelay and see that dhcrelay was started. Although It returns OK, I could not stop it by calling /etc/init.d/dhcrelay stop and whenever I check status It starts new proccess. Then I can only stop it by calling killall dhcrelay command

My installed dhcp package is dhcp-3.0.5-23.el5_6.4

I wonder is there anybody faced with same problem?

share|improve this question

most likely this is simply a broken init.d-script, that does not honor the arguments (start, stop, status), but always starts the dhcprelay.

you might want to report that as a bug with the maintainers of the package.

share|improve this answer
up vote 0 down vote accepted

I figure out the reason of this error. Conf file should not contain commands. I change it as like that and problem solved.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.