Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Running Exchange 2007 on the server with an Outlook 2007 SP2 client, I'm getting an odd message when I try to view specific folders in my Outlook mailbox:

"Cannot display the folder. Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing."

I currently have no unsent messages and no emails opened (I'm just trying to look at the list of emails in the folder)... I found someone suggested setting the following registry setting on the server:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem Value: Disable Session Limit

However I don't see that parameter in the registry, and I'm a little hesitant to just add it without knowing if it applies to Exchange 2007 or an older version.

share|improve this question
A bit of research points to the Google Desktop Search addon... Still looking into it – gharper Jul 28 '09 at 15:57
Odd... after disabling the GDS toolbar & restarting Outlook, I confirmed the problem went away. I re-enabled the GDS toolbar and tried to recreate the problem, but wasn't able to get the error message to come up again. Still trying to find out how to recreate the issue. – gharper Jul 28 '09 at 16:21
My current best guess is when GDS indexes Outlook, it's making MAPI connections & not closing them (the error occurs at 500 connections)... My current fix is to restart GDS and Outlook - I'll leave this question open in case someone has a better answer. – gharper Jul 31 '09 at 15:51

Have you tried this KB article?

There was a Technet newsgroups moderator that suggested it.

It appears to be only an issue with Outlook 07 itself, not Outlook 03 clients don't seem to have this issue. It appears to be related to large numbers of RPC calls or large numbers of folders in a mailbox (or even an attached additional mailbox you are connected to).

Is Outlook at sp2 (office 07 sp2)?

share|improve this answer
It appears that hotfix was included in SP2, and yes, SP2 is installed. (The hotfix won't install, saying the version is incorrect) – gharper Jul 28 '09 at 16:10
up vote 0 down vote accepted

Turns out it is indeed being caused by Google Desktop Search indexing Outlook. As I noted in my previous comment, it's making MAPI connections & not closing them, throwing an error at 500 connections... Unfortunately, I still haven't found a fix other than closing & re-running Outlook & GDS.

If anyone can provide a fix for this, please post it and I'll change the accepted answer.

share|improve this answer

share|improve this answer
Answers really ought to have useful and relevant information in them, not just links. Especially if an answer has already been chosen for the question. – Thomas Mar 26 '14 at 14:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.