Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used to use CheckPoint's VPN client on my Mac OS X (Leopard), but recently I upgraded to Snow Leopard, my VPN client stop working right after that, so I downloaded IPSecuritas and after some time I was able to VPN in. The problem is I get disconnected and since I work through ssh, it's gets very annoying. any ideas where can I look?

share|improve this question

I don't think snow leopard has been released yet, and is still under NDA/beta. Not sure how much help you'll get here on this.

share|improve this answer
Snow Leopard is due for release in September sometime. – Chealion Jul 28 '09 at 22:34
I've been running preview build for a while and I think it's pretty stable, I haven't had any problems at all, and it's more IPSecuritas and CheckPoint question rather then Mac OS X – alexus Jul 28 '09 at 22:41
up vote 1 down vote accepted

after very long time playing around i was able to solve this issue

first of all in "Options" i had uncheck MODE_CFG and the other thing I did was under "General" local side endpoint suppose to be select as a host and that field should be empty, after that it works perfectly for me, no disconnections at all

share|improve this answer

Have you tried Cisco VPN Client (port for OS X)? May work! :D

Download here:

share|improve this answer
i haven't tried with snow leopard but i know for a fact it won't work with checkpoint, i used to use it with cisco on leopard it worked great – alexus Jul 28 '09 at 23:13
Bummer, have you tried configuring your client as "site" vpn (IPSec)? I think Checkpoint uses some proprietary "user-vpn" crap. May be worth looking at VPNC - , not sure if it would be any help at all, but worth a try. – xbnevan Jul 29 '09 at 16:09

Agreed - configuring IPSecuritas is non-trivial and you need to know specifics about your network settings and configuration. Any advice on a likely route forward?

share|improve this answer

By changing two binary files of Checkpoints VPN Client it works on Snow Leopard.

share|improve this answer


Harald Haentsch completely solved this problem by making a very easy to use tutorial on how to "fix" SecureClient to run in OSX 10.6 Snow Leopard:

I just followed the existing installation steps (I used Hex Fiend instead of 0xED, but any HEX editor should work fine) and it was working in 5 minutes on my Snow Leopard upgrade from OSX 10.5.7.

If you're a techy type and want to know more about the "upgrade existing installation" option ... apparently the only reason SecureClient doesn't work in Snow Leopard is because Checkpoint hard coded "kextload -s" instead of "kextload -d" in the startup files for the SecureClient program. Snow Leopard doesn't support "-s", but it supports "-d" so all you have to do is copy 2 files from the SecureClient program to a temporary directory, modify the 2 files and copy them back.

Super easy, guaranteed. It looks like fixing the installation file is also very easy and possibly not necessary in some "new install" situations.



share|improve this answer

protected by Jeff Atwood Jun 8 '10 at 5:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.