Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

By default, my mail server (Snow Leopard) contains an entry to only accept SMTP relays from 127.0.0.0/8. However, when I attempt to check the option and save, the computer unchecks it. When I change the IP address to just 127.0.0.0, I don't experience the unchecking problem. There are two possible solutions: either do you know what is causing the unchecking problem (or which configuration file should I edit to manually do this?), or is it acceptable to simply only have 127.0.0.0 as the IP address?

enter image description here

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I don't have a 10.6 server handy to check with, but I'm pretty sure the default ("Accept SMTP..." option unchecked) setting is to allow relay from 127.0.0.0/8. Essentially, there are two different ways to get the same setting, you're entering one, and it's displaying the other. You can verify this by looking in /etc/postfix/main.cf for a line starting with "mynetworks =".

share|improve this answer
    
I checked the option, changed mynetworks to 127.0.0.1/8, and it works. Thanks for your help! –  Jack Humphries Jan 19 '13 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.