Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So i've been searching the past couple days trying to figure out the best way to achieve this but still can't get it figured out.

I have a debian server setup running Proxmox to host OpenVZ and Qemu virtual machines. I've been assigned two subnets from my provider on the same uplink port. My ultimate goal is to have the Qemu bridged to eth1 and OpenVZ routed to eth1. I want to use OpenVZ routing (venet) because of the ease to provision servers.

In theory this is what i'm trying to do (Gateway can be 200.x.x.41 or 200.x.x.97):

/// Gateway 200.x.x.x ///
           |
           |
   ///    eth1    ///
        |       |
        |       |
//qemu br//   //openvz venet//

Over the past couple days i've tried almost every configuration I can think of and seem to run into the problem of either qemu works or openvz works.

The routing method for openvz i want to use (venet) does not support bridging which is why I think it doesn't work when i have bridge_ports eth1 setup for a bridge as then the routing table shows the default gateway as br0, but i could be wrong.

I have two subnets that are routed to my eth1 port, 200.x.x.40/29 and 200.x.x.96/27. I would like to use the 200.x.x.96/27 subnet for OpenVZ and 200.x.x.40/29 for Qemu.

Is this even physically possible without multiple nics?

Can someone please help me out or at least point me in the right direction, i've pulled out what hair I have left and I cant help but think it's something simple that i'm over-complicating or just not seeing.

Thanks for any help in advance, it is greatly appreciated!!

share|improve this question

1 Answer 1

WOO HOO I figured it out!! In case anybody else runs into this problem, all you need is to enable proxy_arp on the bridged interface!!

auto lo
iface lo inet loopback

iface eth1 inet manual

auto vmbr0
iface vmbr0 inet static
    address  209.x.x.42
    netmask  255.255.255.248
    gateway  209.x.x.41
    bridge_ports eth1
    bridge_stp off
    bridge_fd 0
    post-up echo 1 > /proc/sys/net/ipv4/conf/vmbr0/proxy_arp

So as you can see, I used the 208.x.x.41/29 subnet for the bridge and then enabled proxy_arp on the bridge (vmbr0) and voila!

Since i'm using the venet routing method you don't actually need to specify the other subnet in the configuration, which makes it even easier when adding additional subnets later on!

I also changed the value of VE_ROUTE_SRC_DEV in /etc/vz/vz.conf to:

VE_ROUTE_SRC_DEV="vmbr0"
share|improve this answer
    
Would LOVE to get your help on this if possible! pls contact me qrpike [at] gmail [dot] com –  Quinton Pike Mar 3 '13 at 1:22
    
Sorry didn't get an email about the comment added, post your question so others can share from the fix. Join #proxmox on freenode i'm in there almost daily. –  Myles Mar 13 '13 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.