Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to linux. I'm trying to install VirtualBox in my Ubuntu 12.04 but while installing from terminal the installation stopped with the below error.

So I tried to install it from Ubuntu Software center, but it tells me that it got corrupted and run apt-get install -f in the terminal.

"This should NOT be done unless you know exactly what you are doing! python-minimal python2.7-minimal (due to python-minimal)"

When I did that it broken my entire system. I reinstalled it from scratch and trying again to install VirtualBox but still the same issue. How can I repair this?

share|improve this question

closed as off topic by EEAA, Michael Hampton, Ward, mdpc, Khaled Jan 19 '13 at 7:54

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 0 down vote accepted

You're doing it the wrong way.

First of all, it appears you attempt to install VirtualBox for i386 architecture, while your Ubuntu is amd64. Use amd64, this will prevent multiarch issues.

Then, use the Oracle repository to get the debian package and properly install VirtualBox with all the dependencies automatically solved :

In /etc/apt/sources.list, add deb precise contrib. Then, do wget -q -O- | sudo apt-key add -. Finally, do sudo apt-get update and sudo apt-get install virtualbox-4.2

Before doing this, do not forget to remove your half-installed package using dpkg -r virtualbox-4.2:i386.

share|improve this answer
yes,,now everything great...thank you so much..but im not sure how it is amd64 while I'm using Intel core to check this...anyway dpkg --print-architecture shows its amd64 – Guruji Jan 19 '13 at 9:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.