Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

yesterday I upgraded my fedora box to the latest version, and with that, I also upgraded samba, now using samba 4. I used to access those share from any computer at home without user/password, but now there seems to be something wrong with the configuration.

Here is my smb.conf

[global]
    workgroup = mygroup
    server string = Samba Server Version %v
    netbios name = HOME-WS
    log file = /var/log/samba/log.%m
    max log size = 50
    guest ok = yes
    security = share

[Media]
    path = /mnt/Media
    read only = yes
    browseable = yes
    guest ok = yes
    guest only = yes

[Music]
    path = /mnt/Music
    read only = yes
    browseable = yes
    guest ok = yes
    guest only = yes

Looking at the logs, there is a warning related to the security parameter

 WARNING: Ignoring invalid value 'share' for parameter 'security'

Does that means that samba 4 has finally removed 'share' as an option, is there any alternative to it, so that I can configure shares without passwords.

share|improve this question
    
See the "guest access" section at the bottom of this page. wiki.samba.org/index.php/Frequently_Asked_Questions – JasonAzze Jan 19 '13 at 18:23
    
You are my hero. I don't believe anyone else with only 158 reputation has a gold badge :). – Daniel Feb 28 at 9:00
up vote 15 down vote accepted

If you follow the FAQ link from JasonAzze, you will see there is a "map to guest" line which is also required, so you need both of these lines:

security = user
map to guest = Bad Password

I had the same problem as the OP, and I have tested that this solution works on Fedora 18

share|improve this answer
1  
Thanks, worked great! From smb.conf man page: "(map to guest) Bad User - Means user logins with an invalid password are rejected, unless the username does not exist, in which case it is treated as a guest login and mapped into the guest account." Combined with a "guest ok = yes" directive under a share will enable user/password-less browsing. – joelpet Dec 12 '13 at 21:31
    
Thanks, this helped alot. – Daniel Feb 28 at 8:58

Change "security = share" to "security = user"

Reason: both share and server have been deprecated in Samba4.

share|improve this answer

I feel obligated to share this after spending hours trying to get this to work under SAMBA4 - here is my working SAMBA4 smb.conf that does NOT require a password to get to the share from windows

  [global]

  workgroup = HOME

  server string = %h server (Samba, Ubuntu)

  dns proxy = no

  log file = /var/log/samba/log.%m

  max log size = 1000

  syslog = 0

  panic action = /usr/share/samba/panic-action %d

  server role = standalone server

  security = user

  map to guest = Bad Password

  passdb backend = tdbsam

  obey pam restrictions = yes

  unix password sync = yes

  passwd program = /usr/bin/passwd %u

  passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:*        %n\n *password\supdated\ssuccessfully* .

  pam password change = yes

  usershare allow guests = yes


  # VIDEO SHARE
    [HD]
    comment = HD Video Share
    path = /RAID/HD
    public = yes
    writable = yes
    available = yes
    browsable = yes
    guest ok = yes
    create mask = 0777
    directory mask = 0777
share|improve this answer
    
Thank you for sharing, but I still can't make it work. Maybe I'm missing some directory permission... Windows is no longer asking for a password, but says that there's no permission to access the shared folder. – Edgar Rocha Carvalho Aug 3 '15 at 2:25
    
You probably also need to chown your shared folder (in his case RAID/HD) or chmod it so it's globally Readable and eXecutable (chmod o+rX /your/dir) – Warren P Mar 25 at 19:58

I had to remember to do one other thing before I could get this to work... it was to make sure the permissions on my shared unix directory were read/write for the nobody user or the nogroup group. Debian Jessie, Samba 4.1.

share|improve this answer
    
How exactly do you do that? What the heck is the nobodyuser/nobodygroup? – Warren P Mar 25 at 20:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.