Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up my NFS server without doing any bigger changes in configuration files. After that I added these entries to /etc/exports(both paths are valid) on server(


Then I restarted the computer and I tried to get exports list:

$ showmount -e

According to this output there's not problem with connection. Now I want to mount /export to client filesystem(

sudo mount -t nfs4 /mnt

After typing this there's no output and I can't do anything. Another terminal line start is not being displayed. Command is stuck.

Does anybody know am I doing wrong? Please help me.

share|improve this question
up vote 2 down vote accepted


Try changing your /etc/exports to


Then run exportfs -av


sudo mount -t nfs /mnt or -t nfs4

Would be nice if you could post some output from /var/log/messages if there's any error.

share|improve this answer
Works, thanks! Interesting is that when I connect with -t nfs4 it throws this error: mounting failed reason given by server:No such file or directory. It works with -t nfs. But: I have specified rw option, but on client I cannot write my file. Any idea? – user35443 Jan 20 '13 at 8:17
You need to make sure both server having the same uid and guid for the files and folder. Usually distro comes with nfsnobody. chown -R nfsnobody.nfsnobody /export – Rixxie Jan 21 '13 at 2:44

It looks like you are trying to mount your NFS export to the /mnt directory on your client.

You should create a mount point under /mnt, let's say /mnt/foo, and try mounting there.

share|improve this answer
still not works. I've tried /mnt/users subdirectory – user35443 Jan 19 '13 at 18:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.