Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

As newbie, I try to use IPMI with a supermicro mothercard x8dth-if, version 1.0
I decided to use the LAN1, not the dedicated IPMI LAN.
In BIOS I set the address to 192.168.1.199 for IPMI.
My OS is debian-squeeze. I installed ipmitool.
LAN1 address is 192.168.1.35 and I can ping it.
The command ipmitool chassis status returns

Could not open /dev/ipmi0

ls -l /dev/ipmi* returns nothing. ping 192.168.1.199 returns timeout
How can I invetigate more at this level ? Thank you by advance.

share|improve this question
2  
You need to install the OpenIPMI kernel modules. –  David Schwartz Jan 20 '13 at 2:50
    
I thought that IPMI was independant of the OS. And why a ping from a windows machine doesn't work ? why ipmiview installed on a windows machine doesn't see the x8dth-if server ? –  Bertaud Jan 20 '13 at 14:39
2  
IPMI is independent of the OS. But if you want to manage it from the OS, then obviously the OS is going to need an IPMI driver. That's why ls -l /dev/ipmi* returns nothing. You can investigate why it's not working once you have a driver installed so you can use tools like ipmitool. –  David Schwartz Jan 20 '13 at 16:20
    
OK. I installed OpenIPMI but always nothing. Special command for installing the driver ? I installed it on the server: correct ? –  Bertaud Jan 20 '13 at 17:06
    
and nothing about ipmi in /var/log/kern.log –  Bertaud Jan 20 '13 at 17:23
add comment

2 Answers

up vote 3 down vote accepted

There's a couple of issues here:

The "ipmitool" command on it's own uses a local interface to the ipmi controller. This is why you need to load the modules in order to use ipmitool from the same host. If you're on a remote host you can use ipmitool over the network, using something like "ipmitool -I lan -H hostname -U username -P password chassis status", substituing appropriate values for hostname, username and password.

If you're not using the dedicated IPMI controller ethernet port, then you may need to actively tell the IPMI controller to use the onboard ethernet port. These IPMI controllers default to an "auto fallback", so if you have an ethernet cable plugged into the dedicated LAN port at the time the IPMI controller is powered up, it will use the dedicated port, otherwise it will fallback. So if you've changed your mind about which port to use, this might be occuring.

The onboard port the IPMI controller piggybacks on is LAN1. Are you sure you're using LAN1? It may not be the same as the interface that your linux install thinks is eth0.

Finally, I've definitely seen connectivity issues when using IPMI over a non-dedicated port. The way the ethernet controller in the IPMI piggybacks onto your host ethernet port can result in DHCP issues, as well as network card driver crashes. I've also seen the situation where the IPMI IP address on a non-dedicated port is accessible from a remote machine, but not from the local one (which isn't a problem generally, because you can use the ipmitool kernel interface anyway).

I always advocate using a dedicated port where available.

In all cases, to reset the IPMI controller you need to either use the ipmitool interface once you get that working, or to physically remove power from the machine (off at the wall/PDU etc - turning the machine off from the button at the front isn't enough, as the IPMI controller is still powered)

share|improve this answer
    
I just tested this with an X8DTH-6f, and can verify that if you use the onboard ethernet (LAN1) for IPMI, you cannot ping the IPMI IP address from the host itself (no IP connectivity of any kind from the host to the IPMI controller). You can ping it/connect to it from a remote host though. If you use the dedicated ethernet port for IPMI then everything works as expected –  Daniel Lawson Jan 23 '13 at 3:10
    
my error was to not turn off the machine when I moved the cable on the LAN1. Other question: do you monitor your machines from the web, I mean, is your dedicated port accessible from the web thru switche(s)/router(s) as the "OS" network ? –  Bertaud Jan 29 '13 at 23:00
    
These IPMI controllers interface have a firewall, and can be accessed via HTTPS, so it's definitely possible to expose your IPMI interface to the internet with some security on it. Is it a good idea? Not sure. –  Daniel Lawson Feb 4 '13 at 3:52
add comment

Ensure that these kernel modules are loaded prior using ipmitool utility:

modprobe ipmi_si
modprobe ipmi_msghandler
modprobe ipmi_devintf

After modules are successfully loaded you should see at least this in your system's dmesg output:

[    4.611088] ipmi_si 00:0c: Found new BMC (man_id: 0x0028c5, prod_id: 0x0004, dev_id: 0x22)
[    4.611097] ipmi_si 00:0c: IPMI kcs interface initialized

Now you should be able connect to your IPMI via kcs interface using ipmitool or OpenIPMI utilities.

share|improve this answer
    
modprobe ipmi_si returns nothing. Nothing in dmesg (IPMI or BMC) –  Bertaud Jan 20 '13 at 19:15
    
You should load all 3 kernel modules, not just ipmi_si. –  pdaukintis Jan 20 '13 at 19:24
    
modprobe returns nothing for all 3 modules –  Bertaud Jan 20 '13 at 22:34
    
Could you confirm or not that the IPMI IP address can be in the same LAN segment:192.168.1.35 for the OS and 192.168.1.199 for IPMI ? –  Bertaud Jan 20 '13 at 23:26
    
modprobe won't return anything if it succeeds. Once you have completed the modprobe you should be able use "ipmitool chassis status" other commants like "ipmitool lan print" –  Daniel Lawson Jan 22 '13 at 22:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.