Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am currently in the process of migrating some systems, and as part of this I wanted to consolidate phpPgAdmin to a single instance.
But I am unable to make phpPgAdmin connect to remote servers.
Connecting to localhost using sockets is working just fine, but if I set the host to an IP address, such as 10.0.30.2, I get nowhere.
phpPgAdmin just says login failed and nothing shows up in the log on the postgres server.
I have also turned on logging of all packets to the target server in iptables, but not a single packet gets sent from phpPgAdmin.

Anyone have some tips for resolving this issue?

share|improve this question
    
What distribution/version are you using to host phpPgAdmin? Do you know if selinux is enabled? Can you connect to a database running on the localhost? –  becomingwisest Jan 20 '13 at 17:36
    
Any local firewall? Are you on the 10.x.x.x network? –  Milen A. Radev Jan 20 '13 at 19:54
    
I could open the local database just fine. I had a sudden realization SELinux was active on the new box and turning that off solved it. Oh, the frustrations that thing cause.. –  Morten Nilsen Jan 21 '13 at 23:49
add comment

1 Answer

up vote 1 down vote accepted

Just as commented above, this was caused by SELinux blocking outgoing connections from apache to the remote servers. Disabling SELinux and rebooting the server fixed the problem.

Thanks for the input, guys.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.