Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server in AWS/EC2 that is running a MSSQL database with a number of applications accessing it. On occasion, some Cobol batch processes are run against it also. For a while these have been running fine, however over the last couple of days one of them uses all the CPU and runs for hours (in fact, we always run out of patience and kill it).

The issue is that we're struggling to troubleshoot as we can't do anything with the instance while it's running - we can't connect using RDP, anything that we leave running to monitor processor usage seems to just pause. The only way to get back on that we've found so far is Sys Internals PS Suspend or PS Kill.

I've also tried a number of utilities to perform the equivalent of a Unix 'nice' on the process (BES, Process Lasso, Process Tamer), but none of them seem to work. I've also tried changing the Process Affinity (from normal to low), but that seems to make no difference either. Might I be doing something wrong?

Any suggestions gratefully received.

(Windows 2008R2 Datacenter)

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.